summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--HISTORY3
-rwxr-xr-xdeb_release.sh8
-rw-r--r--debian/changelog91
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/copyright30
-rw-r--r--debian/pydist-overrides4
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/source/format1
-rw-r--r--pkg/requirements.pip1
11 files changed, 166 insertions, 1 deletions
diff --git a/HISTORY b/HISTORY
index 6ca54e7..50aab8e 100644
--- a/HISTORY
+++ b/HISTORY
@@ -27,6 +27,9 @@
o disable local only tcp bind on docker containers to allow access to IMAP
and SMTP. Related to #7471.
+0.3.11 Jan 05, 2015:
+ o Port `enum` to `enum34` (Closes #6601)
+
0.3.10 Sept 26, 2014:
o MessageCollection iterator now creates the LeapMessage with the
collection reference, so setFlags will work properly.
diff --git a/deb_release.sh b/deb_release.sh
new file mode 100755
index 0000000..79e7e24
--- /dev/null
+++ b/deb_release.sh
@@ -0,0 +1,8 @@
+#!/bin/zsh
+
+VERSION_FILE="src/leap/mail/_version.py"
+rm ${VERSION_FILE}
+python setup.py freeze_debianver
+sed -i 's/-dirty//g' ${VERSION_FILE}
+git add ${VERSION_FILE}
+git ci -m "freeze debian version"
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..99ef03f
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,91 @@
+leap-mail (0.4.0) unstable; urgency=medium
+
+ * Update to 0.4.0 release.
+ * Update description to fix capitalization and short description
+
+ -- Micah Anderson <micah@leap.se> Thu, 29 Oct 2015 12:14:09 -0400
+
+leap-mail (0.3.11.1) UNRELEASED; urgency=medium
+
+ [ Micah Anderson ]
+ * Update Standards version to 3.9.6 (no changes)
+ * Update debian/copyright to fix space-in-std-shortname
+
+ -- Micah Anderson <micah@leap.se> Tue, 13 Jan 2015 16:49:11 -0500
+
+leap-mail (0.3.11) unstable; urgency=medium
+
+ * Update to 0.3.11 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 08 Jan 2015 14:46:17 -0400
+
+leap-mail (0.3.9.1) unstable; urgency=medium
+
+ * Change twisted dependency for more specific sub-packages.
+
+ -- Ben Carrillo <ben@futeisha.org> Thu, 14 Aug 2014 11:24:06 -0500
+
+leap-mail (0.3.9) unstable; urgency=low
+
+ * Update to 0.3.9 release
+
+ -- Ben Carrillo <ben@futeisha.org> Wed, 09 Apr 2014 16:11:32 -0500
+
+leap-mail (0.3.8) unstable; urgency=low
+
+ * Update to 0.3.8 release
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 10 Dec 2013 18:09:13 -0400
+
+leap-mail (0.3.7) unstable; urgency=low
+
+ * Update to 0.3.7 release
+
+ -- Ben Carrillo <ben@futeisha.org> Fri, 15 Nov 2013 23:24:27 -0200
+
+leap-mail (0.3.6) unstable; urgency=low
+
+ * Update to 0.3.6 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Tue, 05 Nov 2013 11:34:59 -0200
+
+leap-mail (0.3.4) unstable; urgency=low
+
+ * Update to 0.3.4 release.
+
+ -- Micah Anderson <micah@leap.se> Mon, 14 Oct 2013 17:23:10 -0300
+
+leap-mail (0.3.3.1) unstable; urgency=low
+
+ * Add python-leap.soledad.client and python-leap.keymanager to
+ debian/pydist-overrides
+
+ -- Micah Anderson <micah@leap.se> Tue, 24 Sep 2013 20:59:01 -0400
+
+leap-mail (0.3.3) unstable; urgency=low
+
+ * Update to 0.3.3 release.
+
+ -- Micah Anderson <micah@leap.se> Tue, 24 Sep 2013 16:59:35 -0400
+
+leap-mail (0.3.2) unstable; urgency=low
+
+ * Update to 0.3.2 release.
+
+ -- Micah Anderson <micah@leap.se> Thu, 12 Sep 2013 14:21:13 +0200
+
+leap-mail (0.3.1) unstable; urgency=low
+
+ * Update to 0.3.1 release.
+ * Add leap.common to pydist-overrides.
+ * Update debian/control extended description to fit length
+ * Add debian/copyright
+ * Install CHANGELOG.
+
+ -- Micah Anderson <micah@leap.se> Tue, 27 Aug 2013 11:50:38 +0200
+
+leap-mail (0.3.1~pre) unstable; urgency=low
+
+ * Initial import
+
+ -- Micah Anderson <micah@leap.se> Thu, 22 Aug 2013 17:30:34 -0400
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..2955dac
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/leap.mail.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5df8411
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: leap-mail
+Maintainer: Micah Anderson <micah@leap.se>
+Section: python
+Priority: optional
+Build-Depends: python-setuptools (>= 0.6b3), python-all (>= 2.6.6-3), debhelper (>= 9), dh-python
+Standards-Version: 3.9.6
+
+Package: leap-mail
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}, python-twisted-core, python-twisted-mail
+Suggests: bitmask
+Description: LEAP Bitmask client mail support
+ This package contains the client-side Python components that the desktop
+ client uses for interacting with server-side leap_mx. It includes an SMTP
+ proxy and a local IMAP server that will fetch mail from the remote incoming
+ queue backed up by Soledad.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..7a9d97b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,30 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: leap-mail
+Upstream-Contact: info@leap.se
+Source: <http://github.com/leapcode/leap_mail/>
+
+Files: *
+Copyright: 2012,2013 The LEAP Encryption Access Project
+License: GPL-3+ with OpenSSL exception
+ This package is released under the GNU GPL, version 3 or a later revision.
+ For further details see the COPYING file.
+ .
+ On Debian systems, the full text of the GNU General Public
+ License version 3 can be found in the file
+ `/usr/share/common-licenses/GPL-3'.
+ .
+ In addition, as a special exception, the copyright holders give
+ permission to link the code of portions of this program with the
+ OpenSSL library under certain conditions as described in each
+ individual source file, and distribute linked combinations including
+ the two.
+ .
+ You must obey the GNU General Public License in all respects for all
+ of the code used other than OpenSSL. If you modify file(s) with this
+ exception, you may extend this exception to your version of the
+ file(s), but you are not obligated to do so. If you do not wish to do
+ so, delete this exception statement from your version. If you delete
+ this exception statement from all source files in the program, then
+ also delete it here.
+
+# REVIEW-ME This needs a licensecheck -r run !!! -- kali
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
new file mode 100644
index 0000000..4115618
--- /dev/null
+++ b/debian/pydist-overrides
@@ -0,0 +1,4 @@
+zope.interface python-zope.interface
+leap.soledad.client soledad-client ; PEP386
+leap.common python-leap-common ; PEP386
+leap.keymanager leap-keymanager
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e81414a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+# This file was automatically generated by stdeb 0.6.0+git at
+# Thu, 22 Aug 2013 17:30:34 -0400
+
+%:
+ dh $@ --with python2 --buildsystem=python_distutils
+
+override_dh_installchangelogs:
+ dh_installchangelogs CHANGELOG
+
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/pkg/requirements.pip b/pkg/requirements.pip
index 0caa66b..0871319 100644
--- a/pkg/requirements.pip
+++ b/pkg/requirements.pip
@@ -1,4 +1,3 @@
zope.interface
-twisted # >= 12.0.3 ??
zope.proxy
service-identity