diff options
author | Kali Kaneko <kali@leap.se> | 2016-05-18 12:09:20 -0400 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2016-05-18 12:12:11 -0400 |
commit | 811410d24215fb0539f1f0047bf0c621389b3423 (patch) | |
tree | 61ce4078ad7ce5a76f4cafe6b7e386261ed80c2e | |
parent | ced95ad55f6ee60fecb4bf48195b0ca06a6c49da (diff) |
[pkg] update to new versioneer json format
-rw-r--r-- | setup.py | 27 |
1 files changed, 17 insertions, 10 deletions
@@ -62,6 +62,7 @@ cmdclass = versioneer.get_cmdclass() class freeze_debianver(Command): + """ Freezes the version in a debian branch. To be used after merging the development branch onto the debian one. @@ -74,14 +75,20 @@ class freeze_debianver(Command): # unpacked source archive. Distribution tarballs contain a pre-generated copy # of this file. -version_version = '{version}' -full_revisionid = '{full_revisionid}' -""" - templatefun = r""" +import json +import sys + +version_json = ''' +{ + "dirty": false, + "error": null, + "full-revisionid": "FULL_REVISIONID", + "version": "VERSION_STRING" +} +''' # END VERSION_JSON -def get_versions(default={}, verbose=False): - return {'version': version_version, - 'full-revisionid': full_revisionid} +def get_versions(): + return json.loads(version_json) """ def initialize_options(self): @@ -96,9 +103,9 @@ def get_versions(default={}, verbose=False): if proceed != "y": print("He. You scared. Aborting.") return - subst_template = self.template.format( - version=VERSION_SHORT, - full_revisionid=VERSION_REVISION) + self.templatefun + subst_template = self.template.replace( + 'VERSION_STRING', VERSION_SHORT).replace( + 'FULL_REVISIONID', VERSION_REVISION) versioneer_cfg = versioneer.get_config_from_root('.') with open(versioneer_cfg.versionfile_source, 'w') as f: f.write(subst_template) |