summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-08-09 01:44:50 +0900
committerkali <kali@leap.se>2012-08-09 01:44:50 +0900
commitca5af1390603e9d6dddc25071ebc095ced62e527 (patch)
tree083454971cf929b86809c25fc8ddf7b1caabcce2
parentbda0f214d13387e4efceb127f0a8bbb37935f98c (diff)
updated rules
-rw-r--r--debian/control4
-rw-r--r--debian/files1
-rw-r--r--debian/python-leap-client.debhelper.log48
-rw-r--r--debian/python-leap-client.install2
-rw-r--r--debian/python-leap-client.postinst.debhelper7
-rw-r--r--debian/python-leap-client.prerm.debhelper12
-rw-r--r--debian/python-leap-client.substvars4
-rwxr-xr-xdebian/rules7
-rw-r--r--debian/source/include-binaries1
9 files changed, 8 insertions, 78 deletions
diff --git a/debian/control b/debian/control
index d4b38f2..cabb789 100644
--- a/debian/control
+++ b/debian/control
@@ -11,9 +11,9 @@ X-Python-Version: >= 2.7
Package: python-leap-client
Architecture: any
#XXX ???
-Depends: ${shlibs:Depends}, ${misc:Depends}
+#Depends: ${shlibs:Depends}, ${misc:Depends}
Depends: openvpn, python-qt4
#XXX should deprecate python-support methinks
-Build-Depends: debhelper (>= 8.0.0), python-support, pyqt4-dev-tools, python-sphinx
+#Build-Depends: debhelper (>= 8.0.0), python-support, pyqt4-dev-tools, python-sphinx
Description: the encrypted interned toolkit
<insert long description, indented with spaces>
diff --git a/debian/files b/debian/files
deleted file mode 100644
index 1aed53a..0000000
--- a/debian/files
+++ /dev/null
@@ -1 +0,0 @@
-python-leap-client_0.1.0-1_i386.deb unknown extra
diff --git a/debian/python-leap-client.debhelper.log b/debian/python-leap-client.debhelper.log
deleted file mode 100644
index c9704cf..0000000
--- a/debian/python-leap-client.debhelper.log
+++ /dev/null
@@ -1,48 +0,0 @@
-dh_auto_configure
-dh_auto_build
-dh_auto_test
-dh_prep
-dh_installdirs
-dh_auto_install
-dh_install
-dh_installdocs
-override_dh_installchangelogs dh_installchangelogs
-dh_installchangelogs
-dh_installexamples
-dh_installman
-dh_installcatalogs
-dh_installcron
-dh_installdebconf
-dh_installemacsen
-dh_installifupdown
-dh_installinfo
-dh_installinit
-dh_installmenu
-dh_installmime
-dh_installmodules
-dh_installlogcheck
-dh_installlogrotate
-dh_installpam
-dh_installppp
-dh_installudev
-dh_installwm
-dh_installxfonts
-dh_installgsettings
-dh_bugfiles
-dh_ucf
-dh_lintian
-dh_gconf
-dh_icons
-dh_perl
-dh_usrlocal
-dh_link
-dh_compress
-dh_fixperms
-dh_strip
-dh_makeshlibs
-dh_shlibdeps
-dh_installdeb
-dh_gencontrol
-dh_md5sums
-dh_builddeb
-dh_builddeb
diff --git a/debian/python-leap-client.install b/debian/python-leap-client.install
index 11edacf..82bef82 100644
--- a/debian/python-leap-client.install
+++ b/debian/python-leap-client.install
@@ -1,2 +1,2 @@
#usr/share/polkit-1/actions/net.openvpn.gui.leap
-polkit/net.openvpn.gui.leap.policy usr/share/polkit-1/actions/
+#polkit/net.openvpn.gui.leap.policy usr/share/polkit-1/actions/
diff --git a/debian/python-leap-client.postinst.debhelper b/debian/python-leap-client.postinst.debhelper
deleted file mode 100644
index 8b32391..0000000
--- a/debian/python-leap-client.postinst.debhelper
+++ /dev/null
@@ -1,7 +0,0 @@
-
-# Automatically added by dh_python2:
-if which pycompile >/dev/null 2>&1; then
- pycompile -p python-leap-client
-fi
-
-# End automatically added section
diff --git a/debian/python-leap-client.prerm.debhelper b/debian/python-leap-client.prerm.debhelper
deleted file mode 100644
index 5ebc7ff..0000000
--- a/debian/python-leap-client.prerm.debhelper
+++ /dev/null
@@ -1,12 +0,0 @@
-
-# Automatically added by dh_python2:
-if which pyclean >/dev/null 2>&1; then
- pyclean -p python-leap-client
-else
- dpkg -L python-leap-client | grep \.py$ | while read file
- do
- rm -f "${file}"[co] >/dev/null
- done
-fi
-
-# End automatically added section
diff --git a/debian/python-leap-client.substvars b/debian/python-leap-client.substvars
deleted file mode 100644
index 80ba5c8..0000000
--- a/debian/python-leap-client.substvars
+++ /dev/null
@@ -1,4 +0,0 @@
-python:Versions=2.7
-python:Provides=python2.7-leap-client
-python:Depends=python (>= 2.7), python (<< 2.8), python (>= 2.6.6-7~), python
-misc:Depends=
diff --git a/debian/rules b/debian/rules
index ec47a76..8bbab3d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,8 +8,8 @@
#
#
-# needed???
-# DEB_PYTHON_SYSTEM=pysupport
+# needed??? no
+#DEB_PYTHON_SYSTEM=pysupport
# Uncomment this to turn on verbose mode.
#DH_VERBOSE=1
@@ -25,7 +25,8 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
#
test-python%:
- python$* setup.py test -vv
+ #python$* setup.py test -vv
+ run.tests.sh
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
diff --git a/debian/source/include-binaries b/debian/source/include-binaries
new file mode 100644
index 0000000..9868b8e
--- /dev/null
+++ b/debian/source/include-binaries
@@ -0,0 +1 @@
+dist/leap_client-0.1dev-py2.7.egg