summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-08-09 02:11:08 +0900
committerkali <kali@leap.se>2012-08-09 02:11:08 +0900
commit646a917f43b21d9a6371194c67a4404cc6c3ef98 (patch)
tree12bd47b07d6c90ac64ce2f783158dd1764652a6c
parent90e53c5186f975e3c8b26f4cf8632e9c12984a6a (diff)
working deb again
-rw-r--r--debian/control2
-rw-r--r--debian/files1
-rw-r--r--debian/python-leap-client.postinst.debhelper7
-rw-r--r--debian/python-leap-client.prerm.debhelper12
-rw-r--r--debian/python-leap-client.substvars4
-rwxr-xr-xdebian/rules19
6 files changed, 35 insertions, 10 deletions
diff --git a/debian/control b/debian/control
index cabb789..56eac94 100644
--- a/debian/control
+++ b/debian/control
@@ -14,6 +14,6 @@ Architecture: any
#Depends: ${shlibs:Depends}, ${misc:Depends}
Depends: openvpn, python-qt4
#XXX should deprecate python-support methinks
-#Build-Depends: debhelper (>= 8.0.0), python-support, pyqt4-dev-tools, python-sphinx
+Build-Depends: debhelper (>= 8.0.0), python-support, pyqt4-dev-tools, python-sphinx, pep8
Description: the encrypted interned toolkit
<insert long description, indented with spaces>
diff --git a/debian/files b/debian/files
new file mode 100644
index 0000000..1aed53a
--- /dev/null
+++ b/debian/files
@@ -0,0 +1 @@
+python-leap-client_0.1.0-1_i386.deb unknown extra
diff --git a/debian/python-leap-client.postinst.debhelper b/debian/python-leap-client.postinst.debhelper
new file mode 100644
index 0000000..8b32391
--- /dev/null
+++ b/debian/python-leap-client.postinst.debhelper
@@ -0,0 +1,7 @@
+
+# Automatically added by dh_python2:
+if which pycompile >/dev/null 2>&1; then
+ pycompile -p python-leap-client
+fi
+
+# End automatically added section
diff --git a/debian/python-leap-client.prerm.debhelper b/debian/python-leap-client.prerm.debhelper
new file mode 100644
index 0000000..5ebc7ff
--- /dev/null
+++ b/debian/python-leap-client.prerm.debhelper
@@ -0,0 +1,12 @@
+
+# Automatically added by dh_python2:
+if which pyclean >/dev/null 2>&1; then
+ pyclean -p python-leap-client
+else
+ dpkg -L python-leap-client | grep \.py$ | while read file
+ do
+ rm -f "${file}"[co] >/dev/null
+ done
+fi
+
+# End automatically added section
diff --git a/debian/python-leap-client.substvars b/debian/python-leap-client.substvars
new file mode 100644
index 0000000..80ba5c8
--- /dev/null
+++ b/debian/python-leap-client.substvars
@@ -0,0 +1,4 @@
+python:Versions=2.7
+python:Provides=python2.7-leap-client
+python:Depends=python (>= 2.7), python (<< 2.8), python (>= 2.6.6-7~), python
+misc:Depends=
diff --git a/debian/rules b/debian/rules
index 8bbab3d..152bc0d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,39 +8,40 @@
#
#
-# needed??? no
+# needed??? no, should transition to use dhpython2
+# http://wiki.debian.org/Python/TransitionToDHPython2
+#
#DEB_PYTHON_SYSTEM=pysupport
+
# Uncomment this to turn on verbose mode.
#DH_VERBOSE=1
PYTHON2=$(shell pyversions -vr)
%:
- dh $@ --with python2
- #,sphinxdoc
+ dh $@ --with python2 --buildsystem=python_distutils #,sphinxdoc
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
#
test-python%:
- #python$* setup.py test -vv
- run.tests.sh
+ ./run_tests.sh
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
#dh_auto_build should be enough to build the python2 version
-#build-python%:
-# python$* setup.py build
+build-python%:
+ python$* setup.py build
#override_dh_auto_build: $(PYTHON3:%=build-python%)
# dh_auto_build
-#install-python%:
-# python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
+install-python%:
+ python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
#override_dh_auto_install: $(PYTHON3:%=install-python%)
# dh_auto_install