[pkg] separate leap requirements