summaryrefslogtreecommitdiff
path: root/main/openvpn/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'main/openvpn/configure.ac')
-rw-r--r--main/openvpn/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/openvpn/configure.ac b/main/openvpn/configure.ac
index 55c40847..cb7a5d33 100644
--- a/main/openvpn/configure.ac
+++ b/main/openvpn/configure.ac
@@ -786,7 +786,8 @@ if test "${have_openssl_crypto}" = "yes"; then
LIBS="${saved_LIBS}"
fi
-if test "${have_openssl_ssl}" = "yes"; then
+if test "${enable_ssl}" = "yes" && test "${with_crypto_library}" = "openssl";
+then
saved_CPPFLAGS="${CPPFLAGS}"
CPPFLAGS="${CPPFLAGS} ${OPENSSL_CRYPTO_CFLAGS}"
AC_MSG_CHECKING([for SSL_OP_NO_TICKET flag in OpenSSL])