summaryrefslogtreecommitdiff
path: root/main/openvpn/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'main/openvpn/configure.ac')
-rw-r--r--main/openvpn/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/main/openvpn/configure.ac b/main/openvpn/configure.ac
index 70c0c8b5..55c40847 100644
--- a/main/openvpn/configure.ac
+++ b/main/openvpn/configure.ac
@@ -230,6 +230,13 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [werror],
+ [AS_HELP_STRING([--enable-werror], [promote compiler warnings to errors, will cause builds to fail is the compiler issues warnings (debugging option) @<:@default=no@:>@])],
+ ,
+ [enable_werror="no"]
+)
+
+AC_ARG_ENABLE(
[strict-options],
[AS_HELP_STRING([--enable-strict-options], [enable strict options check between peers (debugging option) @<:@default=no@:>@])],
,
@@ -1121,6 +1128,9 @@ fi
if test "${enable_strict}" = "yes"; then
CFLAGS="${CFLAGS} -Wall -Wno-unused-parameter -Wno-unused-function"
fi
+if test "${enable_werror}" = "yes"; then
+ CFLAGS="${CFLAGS} -Werror"
+fi
if test "${WIN32}" = "yes"; then
test -z "${MAN2HTML}" && AC_MSG_ERROR([man2html is required for win32])