more re-organization
authorMicah Anderson <micah@riseup.net>
Wed, 4 Nov 2015 23:12:06 +0000 (18:12 -0500)
committerMicah Anderson <micah@riseup.net>
Wed, 4 Nov 2015 23:19:00 +0000 (18:19 -0500)
pages/linux/en.text

index 39894ae..ff9782e 100644 (file)
@@ -5,33 +5,49 @@
 
 h2. Introduction
 
-For GNU/Linux, please use one of the following installation methods depending on what distribution you are running.
+For GNU/Linux, we recommend following the installation method detailed below based on what distribution you are running.
 
-To find out which distribution you are running, opena terminal and type in the following:
+To find out which distribution you are running, open a terminal and type in the following:
 
 bc. cat /etc/issue
 
 h2. Ubuntu
 
-For Ubuntu, we only provide packages for Wily Werewolf (15.10) and Vivid Vervet (15.04). This is the recommended method of installing Bitmask. If installed as a package, Bitmask will run faster, be better integrated in the system, and will be kept up to date.
+There are two ways to install bitmask on Ubuntu, via packages and via bundles. If you are comfortable with the command line, we recommend using packages when available, otherwise use the bundle. If installed as a package, Bitmask will run faster, be better integrated in the desktop environment, and will be faster to start.
 
-If you are using Trusty, then you will use the bundle method.
+For Ubuntu, we only provide packages for Wily Werewolf (15.10) and Vivid Vervet (15.04).
+
+If you are using Trusty, then you will need to use the bundle method.
 
 We are sorry, Precise Penguin (12.04) is not working at this time.
 
-h3. Wily Werewolf (15.10)
+h3. Bundle
 
-<%= render({:partial => 'via_packages'}, {:distro => 'wily'}) %>
+First determine if you running a 32 bit or 64 bit kernel by running the following command:
 
-h3. Vivid Vervet (15.04)
+bc. uname -m
 
-<%= render({:partial => 'via_packages'}, {:distro => 'vivid'}) %>
+If the result is:
 
-h3. Trusty Tahr (14.04)
+* @x86_64@, you have *64 bit*
+* @i686@, you have *32 bit*
+* @i386@, you have *32 bit*
 
-For Ubuntu, we only provide packages for Wily Werewolf (15.10) and Vivid Vervet (15.04). If you are using Trusty, then you will use the bundle method.
+Then download the appropriate version below:
+
+* 64 bit kernel
 
-@Bundle Installation@
+<%= render({:partial => 'common/download_button'}, {:link => 'https://dl.bitmask.net/client/linux/stable/Bitmask-linux64-latest.tar.bz2', :text => 'Download 64 bit'}) %>
+
+[[Signature file => https://dl.bitmask.net/client/linux/stable/Bitmask-linux64-latest.tar.bz2.asc]]
+
+* 32 bit kernel
+
+<%= render({:partial => 'common/download_button'}, {:link => 'https://dl.bitmask.net/client/linux/stable/Bitmask-linux32-latest.tar.bz2', :text => 'Download 32 bit'}) %>
+
+[[Signature file => https://dl.bitmask.net/client/linux/stable/Bitmask-linux32-latest.tar.bz2.asc]]
+
+If you want to make sure that the Bitmask wasn't messed with during download you can [[authenticate the signature => signature-verification]].
 
 *NOTE:*
   Stand-alone bundles are useful if want to run Bitmask from a thumb drive. Or from a distribution which we don't support with packages.
@@ -39,6 +55,26 @@ For Ubuntu, we only provide packages for Wily Werewolf (15.10) and Vivid Vervet
     * The Bitmask app will be less well integrated with the desktop environment.
     * Running from the bundle is slower to start than via packages.
 
+h3. Packages
+
+*Wily Werewolf (15.10)*
+
+<%= render({:partial => 'via_packages'}, {:distro => 'wily'}) %>
+
+*Vivid Vervet (15.04)*
+
+<%= render({:partial => 'via_packages'}, {:distro => 'vivid'}) %>
+
+h2. Debian
+
+There are two ways to install bitmask on Debian, via packages and via bundles. If you are comfortable with the command line, we recommend using packages when available, if you are comfortable with the command line, otherwise use the bundle. If installed as a package, Bitmask will run faster, be better integrated in the system, and will be kept up to date.
+
+For Debian, we only provide packages for Stable (Jessie/8), Testing (Stretch) and Unstable (Sid).
+
+If you are using Wheezy, then you will need to use the bundle method.
+
+h3. Bundle
+
 First determine if you running a 32 bit or 64 bit kernel by running the following command:
 
 bc. uname -m
@@ -65,34 +101,26 @@ Then download the appropriate version below:
 
 If you want to make sure that the Bitmask wasn't messed with during download you can [[authenticate the signature => signature-verification]].
 
-h2. Debian
-
-For Debian, we provide packages for the following versions. This is the recommended method of installing Bitmask. If installed as a package, Bitmask will run faster, be better integrated in the system, and will be kept up to date.
+h3. Packages
 
-h3. Stable (Jessie/8)
+*Stable (Jessie/8)*
 
 <%= render({:partial => 'via_packages'}, {:distro => 'jessie', :os => 'debian'}) %>
 
-h3. Testing (Stretch)
+*Testing (Stretch)*
 
 <%= render({:partial => 'via_packages'}, {:distro => 'testing', :os => 'debian'}) %>
 
-h3. Unstable (Sid)
+*Unstable (Sid)*
 <%= render({:partial => 'via_packages'}, {:distro => 'sid', :os => 'debian'}) %>
 
 h2. Other
 
 Please note that we only provide support for the above versions of Debian and Ubuntu. You are welcome to try and get Bitmask running on another distribution. If you want to try, we recommend attempting to use the bundle (see below), or have a look at [[building it from source => https://leap.se/en/docs/get-involved/source]].
 
-*NOTE:*
-  Stand-alone bundles are useful if want to run Bitmask from a thumb drive. Or from a distribution which we don't support with packages.
-  There are two disadvantages to the stand-alone bundle:
-    * The Bitmask app will be less well integrated with the desktop environment.
-    * Running from the bundle is slower to start than via packages.
+h3. Bundle
 
-@Bundle Installation@
-
-How do you tell if you running a 32 bit or 64 bit kernel? Run the following command:
+First determine if you running a 32 bit or 64 bit kernel by running the following command:
 
 bc. uname -m