regenerate
[dl_bitmask_net.git] / public / linux / index.en.html
1 <!DOCTYPE html>
2 <html lang='en'>
3 <head>
4 <title>
5 Linux - Bitmask Downloads
6 </title>
7 <meta content='width=device-width, initial-scale=1.0' name='viewport'>
8 <meta charset='utf-8'>
9 <link href='/assets/bootstrap.min.css' rel='stylesheet'>
10 <link href='/assets/font-awesome/css/font-awesome.min.css' rel='stylesheet'>
11 <link href='/assets/style.css' rel='stylesheet'>
12 <script src='/assets/js/jquery.min.js'></script>
13 </head>
14 <body>
15 <a class='bm-masthead' href='/'></a>
16 <div class='bm-bar'>
17 Bitmask Downloads
18 </div>
19 <div class='bm-main container'>
20 <div id="TOC"><ol>
21   <li>
22     <a href="#download-stand-alone-bundle">Download stand-alone bundle</a>
23     <ol>
24       <li>
25         <a href="#64-bit-kernel">64 bit kernel</a>
26       </li>
27       <li>
28         <a href="#32-bit-kernel">32 bit kernel</a>
29       </li>
30     </ol>
31   </li>
32   <li>
33     <a href="#install-as-packages">Install as packages</a>
34     <ol>
35       <li>
36         <a href="#ubuntu-1510-wily-werewolf">Ubuntu 15.10 (Wily Werewolf)</a>
37       </li>
38       <li>
39         <a href="#ubuntu-1504-vivid-vervet">Ubuntu 15.04 (Vivid Vervet)</a>
40       </li>
41       <li>
42         <a href="#debian-80-jessie">Debian 8.0 (Jessie)</a>
43       </li>
44     </ol>
45   </li>
46   <li>
47     <a href="#upgrading">Upgrading</a>
48   </li>
49 </ol></div>
50
51 <p><div class='row'>
52   <div class='col-sm-8 col-sm-offset-2'>
53     <div class='p alert alert-info'>
54       <b>NOTE:</b> Encrypted email support in Bitmask is still experimental.
55     </div>
56   </div>
57 </div>
58 </p>
59 <p>There are two ways to install Bitmask &#8211; via the stand-alone bundles or via packages.</p>
60 <h2><a name="download-stand-alone-bundle"></a>Download stand-alone bundle</h2>
61 <h3><a name="64-bit-kernel"></a>64 bit kernel</h3>
62 <p><a class='btn btn-primary btn-large' href='https://dl.bitmask.net/client/linux/stable/Bitmask-linux64-latest.tar.bz2'>
63   <i class='fa fa-cloud-download fa-lg'></i>
64   Download 64 bit
65 </a>
66 </p>
67 <p><a href="https://dl.bitmask.net/client/linux/stable/Bitmask-linux64-latest.tar.bz2.asc">Signature file</a></p>
68 <h3><a name="32-bit-kernel"></a>32 bit kernel</h3>
69 <p><a class='btn btn-primary btn-large' href='https://dl.bitmask.net/client/linux/stable/Bitmask-linux32-latest.tar.bz2'>
70   <i class='fa fa-cloud-download fa-lg'></i>
71   Download 32 bit
72 </a>
73 </p>
74 <p><a href="https://dl.bitmask.net/client/linux/stable/Bitmask-linux32-latest.tar.bz2.asc">Signature file</a></p>
75 <p>If you want to make sure that the Bitmask wasn&#8217;t messed with during download<br />
76 you can <a href="/en/signature-verification">authenticate the signature</a>.</p>
77 <p>How do you tell if you running a 32 bit or 64 bit kernel? Run the following command:</p>
78 <pre><code>uname -m</code></pre>
79 <p>If the result is:</p>
80 <ul>
81         <li><code>x86_64</code>, you have <strong>64 bit</strong></li>
82         <li><code>i686</code>, you have <strong>32 bit</strong></li>
83         <li><code>i386</code>, you have <strong>32 bit</strong></li>
84 </ul>
85 <p><span class="caps">NOTE</span>:<br />
86   Stand-alone bundles are useful if want to run Bitmask from a thumb drive. Or from a distribution which we don&#8217;t support with packages.<br />
87   There are two disadvantages to the stand-alone bundle:</p>
88 <ul>
89         <li>The Bitmask app will be less well integrated with the desktop environment.</li>
90         <li>Running from the bundle is slower to start than via packages.</li>
91 </ul>
92 <h2><a name="install-as-packages"></a>Install as packages</h2>
93 <p>This is the recommended method of installing Bitmask. If installed as a package, Bitmask will run faster, be better integrated in the system, and will be kept up to date.</p>
94 <h3><a name="ubuntu-1510-wily-werewolf"></a>Ubuntu 15.10 (Wily Werewolf)</h3>
95 <p><p class='b'>To install</p>
96 <pre>sudo -s&#x000A;add-apt-repository "deb http://deb.bitmask.net/debian wily main"&#x000A;wget -O- https://dl.bitmask.net/apt.key | apt-key add -&#x000A;apt-get update&#x000A;apt-get install bitmask leap-keyring&#x000A;</pre>
97 <p class='b'>To remove</p>
98 <pre>sudo -s&#x000A;apt-get remove bitmask leap-keyring&#x000A;apt-key del 0x1E34A1828E207901&#x000A;add-apt-repository --remove "deb http://deb.bitmask.net/debian wily main"</pre>
99 </p>
100 <h3><a name="ubuntu-1504-vivid-vervet"></a>Ubuntu 15.04 (Vivid Vervet)</h3>
101 <p><p class='b'>To install</p>
102 <pre>sudo -s&#x000A;add-apt-repository "deb http://deb.bitmask.net/debian vivid main"&#x000A;wget -O- https://dl.bitmask.net/apt.key | apt-key add -&#x000A;apt-get update&#x000A;apt-get install bitmask leap-keyring&#x000A;</pre>
103 <p class='b'>To remove</p>
104 <pre>sudo -s&#x000A;apt-get remove bitmask leap-keyring&#x000A;apt-key del 0x1E34A1828E207901&#x000A;add-apt-repository --remove "deb http://deb.bitmask.net/debian vivid main"</pre>
105 </p>
106 <h3><a name="debian-80-jessie"></a>Debian 8.0 (Jessie)</h3>
107 <p><p class='b'>To install</p>
108 <pre>sudo -s&#x000A;echo "deb http://deb.bitmask.net/debian jessie main" > /etc/apt/sources.list.d/bitmask.list&#x000A;wget -O- https://dl.bitmask.net/apt.key | apt-key add -&#x000A;apt-get update&#x000A;apt-get install bitmask leap-keyring&#x000A;</pre>
109 <p class='b'>To remove</p>
110 <pre>sudo -s&#x000A;apt-get remove bitmask leap-keyring&#x000A;apt-key del 0x1E34A1828E207901&#x000A;rm /etc/apt/sources.list.d/bitmask.list&#x000A;</pre>
111 </p>
112 <h2><a name="upgrading"></a>Upgrading</h2>
113 <p><strong>From stand-alone bundles</strong>: Bitmask should upgrade itself automatically (for versions equal or later than 0.7.0). If you are running a version prior to 0.7.0, you can download the new bundle and copy the &#8220;config&#8221; folder from the old bundle directory.</p>
114 <p><strong>From packages</strong>: If you are running from packages, then you can trigger an update like so:</p>
115 <pre><code>apt-get update
116 apt-get dist-upgrade</code></pre>
117 <p><span class="caps">NOTE</span>: When upgrading Ubuntu from 14.10 (Utopic) to 15.04 (Vivid), you may need to run this command again:</p>
118 <pre><code>sudo add-apt-repository "deb <a href="http://deb.bitmask.net/debian">deb.bitmask.net/debian</a> vivid main"</code></pre>
119 <p>Similar is needed for the upgrade from 15.04 to 15.10 (Wily):</p>
120 <pre><code>sudo add-apt-repository "deb <a href="http://deb.bitmask.net/debian">deb.bitmask.net/debian</a> wily main"</code></pre>
121 <p>This is because the Ubuntu upgrade process probably commented out all your prior custom repository lines in <code>/etc/apt/sources.list</code>.</p>
122 </div>
123 <footer>
124 <div>
125 (c) 2014 LEAP Encryption Access Project
126 </div>
127 <div>
128 Everything available for download on this site is free and open source software.
129 <br>
130 Source code available from
131 <a href="https://leap.se/git/">https://leap.se/git</a>
132 or
133 <a href="https://github.com/leapcode">https://github.com/leapcode</a>.
134 </div>
135 </footer>
136 </body>
137 </html>