summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 39eadea2..39073a2a 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -48,6 +48,14 @@ install-data-hook:
if test ! -f "$(DESTDIR)/$(localconfdir)/local.ini"; then \
cp $(srcdir)/local.ini "$(DESTDIR)/$(localconfdir)/local.ini"; \
fi
+ if test ! "$(mkdir_p)" = ""; then \
+ $(mkdir_p) "$(DESTDIR)/$(localconfdir)/default.d"; \
+ $(mkdir_p) "$(DESTDIR)/$(localconfdir)/local.d"; \
+ else \
+ echo "WARNING: You may have to create these directories by hand."; \
+ mkdir -p "$(DESTDIR)/$(localconfdir)/default.d"; \
+ mkdir -p "$(DESTDIR)/$(localconfdir)/local.d"; \
+ fi
uninstall-local:
rm -f "$(DESTDIR)/$(localconfdir)/local.ini"