summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index baf588ea..2910fe2f 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -11,14 +11,17 @@
## under the License.
couchprivlibdir = $(localerlanglibdir)/couch-$(version)/priv/lib
+devcouchprivlibdir = $(abs_top_srcdir)/src/couchdb/.libs
localconf_DATA = default.ini
EXTRA_DIST = local.ini
+noinst_DATA = default_dev.ini
-CLEANFILES = $(localconf_DATA)
+CLEANFILES = $(localconf_DATA) $(noinst_DATA)
transform = @program_transform_name@
couchjs_command_name = `echo couchjs | sed '$(transform)'`
+couchjs_dev_command_name = `echo couchjs_dev | sed '$(transform)'`
default.ini: default.ini.tpl
sed -e "s|%bindir%|$(bindir)|g" \
@@ -30,6 +33,16 @@ default.ini: default.ini.tpl
-e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
< $< > $@
+default_dev.ini: default.ini.tpl
+ sed -e "s|%bindir%|$(abs_top_srcdir)/bin|g" \
+ -e "s|%localconfdir%|$(abs_top_srcdir)/etc/couchdb|g" \
+ -e "s|%localdatadir%|$(abs_top_srcdir)/share|g" \
+ -e "s|%localstatelibdir%|$(abs_top_srcdir)/tmp/lib|g" \
+ -e "s|%localstatelogdir%|$(abs_top_srcdir)/tmp/log|g" \
+ -e "s|%couchprivlibdir%|$(devcouchprivlibdir)|g" \
+ -e "s|%couchjs_command_name%|$(couchjs_dev_command_name)|g" \
+ < $< > $@
+
install-data-hook:
if test ! -f "$(DESTDIR)/$(localconfdir)/local.ini"; then \
cp local.ini "$(DESTDIR)/$(localconfdir)/local.ini"; \