summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 981b1cc8..690bbb01 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -12,11 +12,9 @@
datarootdir = @prefix@/share
-pkgconf_DATA = couch.ini couch_httpd.conf
+pkgconf_DATA = couch.ini
-nobase_dist_pkgconf_DATA = conf/mime.types
-
-CLEANFILES = $(pkgconf_DATA) $(dist_pkgconf_DATA)
+CLEANFILES = $(pkgconf_DATA)
transform = @program_transform_name@
couchjs_command_name = `echo couchjs | sed '$(transform)'`
@@ -32,10 +30,3 @@ couch.ini: couch.ini.tpl
-e "s|%couchprivlibdir%|$(couchprivlibdir)|g" \
-e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
< $< > $@
-
-couch_httpd.conf: couch_httpd.conf.tpl
- sed -e "s|%pkgconfdir%|@pkgconfdir@|g" \
- -e "s|%pkgdatadir%|@pkgdatadir@|g" \
- -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
- < $< > $@
-