summaryrefslogtreecommitdiff
path: root/bin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/Makefile.am')
-rw-r--r--bin/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/bin/Makefile.am b/bin/Makefile.am
index cb0a827a..93a53192 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -10,7 +10,12 @@
## License for the specific language governing permissions and limitations under
## the License.
+if WINDOWS
+bin_SCRIPTS = couchdb.bat
+else
bin_SCRIPTS = couchdb couchjs
+endif
+
noinst_SCRIPTS = couchjs_dev
if HELP2MAN
@@ -69,6 +74,11 @@ couchjs_dev: couchjs.tpl
$@ < $<
chmod +x $@
+couchdb.bat: couchdb.bat.tpl
+ sed -e "s|%ICU_CONFIG%|$(ICU_CONFIG)|g" \
+ -e "s|%version%|@version@|g" \
+ $< > $@
+
HELP2MAN_OPTION=--no-info --help-option="-h" --version-option="-V"
# XXX: Because the scripts are made at build time for the user we need to