summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e4790d0..5ee69f0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,13 @@ THANKS.gz: $(top_srcdir)/THANKS
check: all
prove test/etap/*.t
+cover: all
+ rm -f cover/*.coverdata
+ COVER=1 COVER_BIN=./src/couchdb/ prove test/etap/*.t
+ SRC=./src/couchdb/ \
+ $(ERL) -noshell -eval 'etap_report:create()' \
+ -s init stop -noshell > /dev/null 2>&1
+
dev: all
@echo "This command is intended for developers to use;"
@echo "it creates development ini files as well as a"