summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am61
1 files changed, 58 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index fff5648b..8e16baf6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,11 +12,38 @@
SUBDIRS = bin etc src share test var utils
-localdoc_DATA = AUTHORS.gz BUGS.gz CHANGES.gz NEWS.gz README.gz THANKS.gz
+ACLOCAL_AMFLAGS = -I m4
+
+localdoc_DATA = \
+ AUTHORS.gz \
+ BUGS.gz \
+ CHANGES.gz \
+ DEVELOPERS.gz \
+ INSTALL.gz \
+ INSTALL.Unix.gz \
+ INSTALL.Windows.gz \
+ LICENSE.gz \
+ NEWS.gz \
+ NOTICE.gz \
+ README.gz \
+ THANKS.gz
DISTCLEANFILES = $(localdoc_DATA)
-EXTRA_DIST = AUTHORS BUGS CHANGES LICENSE NEWS NOTICE README THANKS license.skip
+EXTRA_DIST = \
+ AUTHORS \
+ BUGS \
+ CHANGES \
+ DEVELOPERS \
+ INSTALL \
+ INSTALL.Unix \
+ INSTALL.Windows \
+ LICENSE \
+ NEWS \
+ NOTICE \
+ README \
+ THANKS \
+ license.skip
AUTHORS.gz: $(top_srcdir)/AUTHORS
-gzip -9 < $< > $@
@@ -27,9 +54,27 @@ BUGS.gz: $(top_srcdir)/BUGS
CHANGES.gz: $(top_srcdir)/CHANGES
-gzip -9 < $< > $@
+DEVELOPERS.gz: $(top_srcdir)/DEVELOPERS
+ -gzip -9 < $< > $@
+
+INSTALL.gz: $(top_srcdir)/INSTALL
+ -gzip -9 < $< > $@
+
+INSTALL.Unix.gz: $(top_srcdir)/INSTALL.Unix
+ -gzip -9 < $< > $@
+
+INSTALL.Windows.gz: $(top_srcdir)/INSTALL.Windows
+ -gzip -9 < $< > $@
+
+LICENSE.gz: $(top_srcdir)/LICENSE
+ -gzip -9 < $< > $@
+
NEWS.gz: $(top_srcdir)/NEWS
-gzip -9 < $< > $@
+NOTICE.gz: $(top_srcdir)/NOTICE
+ -gzip -9 < $< > $@
+
README.gz: $(top_srcdir)/README
-gzip -9 < $< > $@
@@ -59,7 +104,13 @@ dev: all
mkdir -p $(top_builddir)/tmp/log
mkdir -p $(top_builddir)/tmp/run/couchdb
+install-data-hook:
+ @echo
+ @echo "You have installed Apache CouchDB, time to relax."
+
distclean-local:
+ rm -fr $(top_builddir)/etc/couchdb/default.d
+ rm -fr $(top_builddir)/etc/couchdb/local.d
rm -fr $(top_builddir)/tmp
.PHONY: local-clean
@@ -74,7 +125,11 @@ local-clean: maintainer-clean
rm -f $(top_srcdir)/test/etap/temp.*
rm -f $(top_srcdir)/*.tar.gz
rm -f $(top_srcdir)/*.tar.gz.*
- find $(top_srcdir) -name Makefile.in -exec rm {} \;
+ find $(top_srcdir) -name Makefile.in -exec rm -f {} \;
+
+dist-hook:
+ find $(top_srcdir) -type f -name "._*" -exec rm -f {} \;
+ find $(top_builddir) -type f -name "._*" -exec rm -f {} \;
distcheck-hook:
grep -rL 'http://www.apache.org/licenses/LICENSE-2.0' * \