summaryrefslogtreecommitdiff
path: root/src/etap/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-09-29 02:38:18 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-09-29 02:38:18 +0000
commite5813d55b0f65d30b3081d0f1a5cd2e7b6f900ed (patch)
tree59bf3af8ae1b074edf286b541eb2cfc550122a0b /src/etap/Makefile.am
parent09c24441707ad620482a70fb768a117602777091 (diff)
Add ETap to CouchDB's SVN repository.
This pulls in ETap as an included dependency. As per directions of the ASF the NOTICE and LICENSE have been updated. Tests have been updated to include etap on Erlang's code path. license.skip was updated for make distcheck. This only affects running the Erlang test suite. Noah is awesome. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@819799 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/etap/Makefile.am')
-rw-r--r--src/etap/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/etap/Makefile.am b/src/etap/Makefile.am
new file mode 100644
index 00000000..732347bf
--- /dev/null
+++ b/src/etap/Makefile.am
@@ -0,0 +1,44 @@
+## Licensed under the Apache License, Version 2.0 (the "License"); you may not
+## use this file except in compliance with the License. You may obtain a copy
+## of the License at
+##
+## http://www.apache.org/licenses/LICENSE-2.0
+##
+## Unless required by applicable law or agreed to in writing, software
+## distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+## WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+## License for the specific language governing permissions and limitations under
+## the License.
+
+etapebindir = $(localerlanglibdir)/etap/ebin
+
+etap_file_collection = \
+ etap.erl \
+ etap_application.erl \
+ etap_can.erl \
+ etap_exception.erl \
+ etap_process.erl \
+ etap_report.erl \
+ etap_request.erl \
+ etap_string.erl \
+ etap_web.erl
+
+etapebin_make_generated_file_list = \
+ etap.beam \
+ etap_application.beam \
+ etap_can.beam \
+ etap_exception.beam \
+ etap_process.beam \
+ etap_report.beam \
+ etap_request.beam \
+ etap_string.beam \
+ etap_web.beam
+
+etapebin_DATA = $(etapebin_make_generated_file_list)
+
+EXTRA_DIST = $(etap_file_collection)
+
+CLEANFILES = $(etapebin_make_generated_file_list)
+
+%.beam: %.erl
+ $(ERLC) $(ERLC_FLAGS) $<