summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorDamien F. Katz <damien@apache.org>2010-06-23 19:11:50 +0000
committerDamien F. Katz <damien@apache.org>2010-06-23 19:11:50 +0000
commitfeb18bd6efc40126bdb4af390419223e10ef134d (patch)
tree0833e401ab28327acf5f377bb929fe8d351502c8 /src/couchdb/Makefile.am
parent918f8bf54a4aeffc3c0ef4ad1fa31ce93bbc1346 (diff)
Authentication caching, to avoid repeated opening and closing of the users database for each request requiring authentication. COUCHDB-807
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@957314 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index a5818703..308a3837 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -17,7 +17,7 @@ couchlibdir = $(localerlanglibdir)/couch-$(version)
couchincludedir = $(couchlibdir)/include
couchebindir = $(couchlibdir)/ebin
-couchinclude_DATA = couch_db.hrl
+couchinclude_DATA = couch_db.hrl couch_js_functions.hrl
couchebin_DATA = $(compiled_files)
# dist_devdoc_DATA = $(doc_base) $(doc_modules)
@@ -29,6 +29,7 @@ CLEANFILES = $(compiled_files) $(doc_base)
source_files = \
couch.erl \
couch_app.erl \
+ couch_auth_cache.erl \
couch_btree.erl \
couch_changes.erl \
couch_config.erl \
@@ -80,12 +81,13 @@ source_files = \
couch_db_updater.erl \
couch_work_queue.erl
-EXTRA_DIST = $(source_files) couch_db.hrl
+EXTRA_DIST = $(source_files) couch_db.hrl couch_js_functions.hrl
compiled_files = \
couch.app \
couch.beam \
couch_app.beam \
+ couch_auth_cache.beam \
couch_btree.beam \
couch_changes.beam \
couch_config.beam \
@@ -194,6 +196,6 @@ endif
# $(ERL) -noshell -run edoc_run files [\"$<\"]
-%.beam: %.erl couch_db.hrl
+%.beam: %.erl couch_db.hrl couch_js_functions.hrl
$(ERLC) $(ERLC_FLAGS) ${TEST} $<;