summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-05-30 21:12:06 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-05-30 21:12:06 +0000
commit9e9230c129816dc2ee7092734e72bffb2ac17748 (patch)
tree72c8419ce3bb95d8e38a8388870e9617e6b0a0da /src/couchdb/Makefile.am
parent2b4436982461eda62e2e4ee2910663ce2a44c146 (diff)
Added code coverage report generation target.
To generate reports: # Assuming etap is installed $ cd /path/to/couchdb $ ./bootstrap && ERLC_FLAGS=+debug_info ./configure && make cover You can browse the report by opening ./cover/index.html in your html consuming software of choice. Shoutout to Nick Gerakines in THANKS for helping with etap and testing in general. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@780326 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index e19a7539..b34155c7 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -169,7 +169,7 @@ couch.app: couch.app.tpl
# $(ERL) -noshell -run edoc_run files [\"$<\"]
%.beam: %.erl couch_db.hrl
- $(ERLC) ${TEST} $<;
+ $(ERLC) $(ERLC_FLAGS) ${TEST} $<;
install-data-hook:
if test -f "$(DESTDIR)/$(couchprivlibdir)/couch_erl_driver"; then \