summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorAdam Kocoloski <kocolosk@apache.org>2009-08-30 17:56:56 +0000
committerAdam Kocoloski <kocolosk@apache.org>2009-08-30 17:56:56 +0000
commit6c5a22e7afd7530148f3eef6d4722cd725f28851 (patch)
tree80862f0920c1f7cb55e7279fd5acfbc27286194a /src/couchdb/Makefile.am
parent422d815b3baf1a0152429d02257aeaeaf6fa471c (diff)
refactor CouchDB startup procedure, see COUCHDB-216 for details
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@809392 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index 13b20c10..95c523c4 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -56,6 +56,8 @@ CLEANFILES = $(compiled_files) $(doc_base)
# CLEANFILES = $(doc_modules) edoc-info
source_files = \
+ couch.erl \
+ couch_app.erl \
couch_btree.erl \
couch_batch_save.erl \
couch_batch_save_sup.erl \
@@ -109,6 +111,8 @@ EXTRA_DIST = $(source_files) couch_db.hrl couch_stats.hrl
compiled_files = \
couch.app \
+ couch.beam \
+ couch_app.beam \
couch_btree.beam \
couch_batch_save.beam \
couch_batch_save_sup.beam \
@@ -189,8 +193,13 @@ compiled_files = \
# couch_view.html
couch.app: couch.app.tpl
+ modules=`find . -name "*.erl" -exec basename -s .erl {} \; | tr '\n' ',' | sed "s/,$$//"`; \
sed -e "s|%package_name%|@package_name@|g" \
- -e "s|%version%|@version@|g" > \
+ -e "s|%version%|@version@|g" \
+ -e "s|@modules@|$$modules|g" \
+ -e "s|%localconfdir%|@localconfdir@|g" \
+ -e "s|@defaultini@|default.ini|g" \
+ -e "s|@localini@|local.ini|g" > \
$@ < $<
chmod +x $@