summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2009-02-22 13:50:38 +0000
committerJan Lehnardt <jan@apache.org>2009-02-22 13:50:38 +0000
commit598eee1cf5979b61171f623da7e3164244ca3792 (patch)
treec9ff009fe39f2f07b060ace1149a8f074040c2a6 /src/couchdb/Makefile.am
parent1ebc2117452516f6ac6f4f458d7372bc710b79d2 (diff)
Add runtime statistics -- without EUnit tests for now.
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@746691 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index 8dd21256..10c06ebe 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -58,6 +58,7 @@ source_files = \
couch_httpd_show.erl \
couch_httpd_view.erl \
couch_httpd_misc_handlers.erl \
+ couch_httpd_stats_handlers.erl \
couch_key_tree.erl \
couch_log.erl \
couch_os_process.erl \
@@ -66,6 +67,8 @@ source_files = \
couch_rep.erl \
couch_server.erl \
couch_server_sup.erl \
+ couch_stats_aggregator.erl \
+ couch_stats_collector.erl \
couch_stream.erl \
couch_task_status.erl \
couch_util.erl \
@@ -96,6 +99,7 @@ compiled_files = \
couch_httpd_show.beam \
couch_httpd_view.beam \
couch_httpd_misc_handlers.beam \
+ couch_httpd_stats_handlers.beam \
couch_key_tree.beam \
couch_log.beam \
couch_os_process.beam \
@@ -104,6 +108,8 @@ compiled_files = \
couch_rep.beam \
couch_server.beam \
couch_server_sup.beam \
+ couch_stats_aggregator.beam \
+ couch_stats_collector.beam \
couch_stream.beam \
couch_task_status.beam \
couch_util.beam \
@@ -152,7 +158,7 @@ couch.app: couch.app.tpl
# $(ERL) -noshell -run edoc_run files [\"$<\"]
%.beam: %.erl couch_db.hrl
- $(ERLC) $<
+ $(ERLC) ${TEST} $<;
install-data-hook:
if test -f "$(DESTDIR)/$(couchprivlibdir)/couch_erl_driver"; then \