summaryrefslogtreecommitdiff
path: root/src/couchdb/Makefile.am
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2010-05-22 21:46:08 +0000
committerJan Lehnardt <jan@apache.org>2010-05-22 21:46:08 +0000
commit1ea5ee0b22f275aa65f9b0f657f01942f11b3524 (patch)
treefeca661ab72137aa4cf8196a1a0777d5591acd6f /src/couchdb/Makefile.am
parent16a19110eba7c378ade36320598faf10c3c723c9 (diff)
Fix Solaris compat.
Patch by Gavin Sherry and Timothy Smith. Closes COUCHDB-666 \m/ git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@947337 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'src/couchdb/Makefile.am')
-rw-r--r--src/couchdb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/couchdb/Makefile.am b/src/couchdb/Makefile.am
index b5c84f33..a5818703 100644
--- a/src/couchdb/Makefile.am
+++ b/src/couchdb/Makefile.am
@@ -179,7 +179,7 @@ couch.app: couch.app.tpl
$@ < $<
else
couch.app: couch.app.tpl
- modules=`find . -name "*.erl" -exec basename {} .erl \; | tr '\n' ',' | sed "s/,$$//"`; \
+ modules=`{ find . -name "*.erl" -exec basename {} .erl \; | tr '\n' ','; echo ''; } | sed "s/,$$//"`; \
sed -e "s|%package_name%|@package_name@|g" \
-e "s|%version%|@version@|g" \
-e "s|@modules@|$$modules|g" \