summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
authorChristopher Lenz <cmlenz@apache.org>2008-04-15 12:21:00 +0000
committerChristopher Lenz <cmlenz@apache.org>2008-04-15 12:21:00 +0000
commit39de3072bcf9fdeec6d3faeb125924c401242205 (patch)
treeda55307c8762f9ff16f7a7e478d971c0f352d281 /etc/couchdb/Makefile.am
parent53968ddfd93bfe1aa403478de715ae0ac77db177 (diff)
Merged mochiweb branch back into trunk.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@648222 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 981b1cc8..690bbb01 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -12,11 +12,9 @@
datarootdir = @prefix@/share
-pkgconf_DATA = couch.ini couch_httpd.conf
+pkgconf_DATA = couch.ini
-nobase_dist_pkgconf_DATA = conf/mime.types
-
-CLEANFILES = $(pkgconf_DATA) $(dist_pkgconf_DATA)
+CLEANFILES = $(pkgconf_DATA)
transform = @program_transform_name@
couchjs_command_name = `echo couchjs | sed '$(transform)'`
@@ -32,10 +30,3 @@ couch.ini: couch.ini.tpl
-e "s|%couchprivlibdir%|$(couchprivlibdir)|g" \
-e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
< $< > $@
-
-couch_httpd.conf: couch_httpd.conf.tpl
- sed -e "s|%pkgconfdir%|@pkgconfdir@|g" \
- -e "s|%pkgdatadir%|@pkgdatadir@|g" \
- -e "s|%pkgstatelogdir%|@pkgstatelogdir@|g" \
- < $< > $@
-