summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2009-04-21 14:51:17 +0000
committerNoah Slater <nslater@apache.org>2009-04-21 14:51:17 +0000
commit2bc242fda8138ba8f8730f242771399ec5badd72 (patch)
tree583fabd4c80750ae06cd8ef2967302e26f3c1a0b /etc/couchdb/Makefile.am
parent40ff96300b7eb8aa1751d8377b3960157bf57673 (diff)
added new configuration system
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@767164 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 39eadea2..39073a2a 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -48,6 +48,14 @@ install-data-hook:
if test ! -f "$(DESTDIR)/$(localconfdir)/local.ini"; then \
cp $(srcdir)/local.ini "$(DESTDIR)/$(localconfdir)/local.ini"; \
fi
+ if test ! "$(mkdir_p)" = ""; then \
+ $(mkdir_p) "$(DESTDIR)/$(localconfdir)/default.d"; \
+ $(mkdir_p) "$(DESTDIR)/$(localconfdir)/local.d"; \
+ else \
+ echo "WARNING: You may have to create these directories by hand."; \
+ mkdir -p "$(DESTDIR)/$(localconfdir)/default.d"; \
+ mkdir -p "$(DESTDIR)/$(localconfdir)/local.d"; \
+ fi
uninstall-local:
rm -f "$(DESTDIR)/$(localconfdir)/local.ini"