summaryrefslogtreecommitdiff
path: root/etc/couchdb/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2008-06-15 16:49:21 +0000
committerNoah Slater <nslater@apache.org>2008-06-15 16:49:21 +0000
commit081daf1250c079efc38a6be9c04984718d441a1f (patch)
treeefd6494e87b1ccbb520426a61187c3b255d35b5b /etc/couchdb/Makefile.am
parentcd9dd26d15ffa8c0a86d037890d2075d2dafa939 (diff)
removed abspath from makefiles
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@667971 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/couchdb/Makefile.am')
-rw-r--r--etc/couchdb/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/etc/couchdb/Makefile.am b/etc/couchdb/Makefile.am
index 8bb80b4a..dc849354 100644
--- a/etc/couchdb/Makefile.am
+++ b/etc/couchdb/Makefile.am
@@ -19,18 +19,12 @@ couchjs_command_name = `echo couchjs | sed '$(transform)'`
couchprivlibdir = $(erlanglibdir)/couch-$(version)/priv/lib
-abs_bindir = $(abspath $(bindir))
-abs_pkgdatadir = $(abspath $(pkgdatadir))
-abs_pkgconfdir = $(abspath $(pkgconfdir))
-abs_pkgstatelibdir = $(abspath $(pkgstatelibdir))
-abs_pkgstatelogdir = $(abspath $(pkgstatelogdir))
-
couch.ini: couch.ini.tpl
- sed -e "s|%bindir%|$(abs_bindir)|g" \
- -e "s|%pkgconfdir%|$(abs_pkgconfdir)|g" \
- -e "s|%pkgdatadir%|$(abs_pkgdatadir)|g" \
- -e "s|%pkgstatelibdir%|$(abs_pkgstatelibdir)|g" \
- -e "s|%pkgstatelogdir%|$(abs_pkgstatelogdir)|g" \
+ sed -e "s|%bindir%|$(bindir)|g" \
+ -e "s|%pkgconfdir%|$(pkgconfdir)|g" \
+ -e "s|%pkgdatadir%|$(pkgdatadir)|g" \
+ -e "s|%pkgstatelibdir%|$(pkgstatelibdir)|g" \
+ -e "s|%pkgstatelogdir%|$(pkgstatelogdir)|g" \
-e "s|%couchprivlibdir%|$(couchprivlibdir)|g" \
-e "s|%couchjs_command_name%|$(couchjs_command_name)|g" \
< $< > $@