summaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorMark Hammond <mhammond@apache.org>2009-10-17 03:30:05 +0000
committerMark Hammond <mhammond@apache.org>2009-10-17 03:30:05 +0000
commitad18ea644ee7650425320736b10a48a8cbd0d340 (patch)
tree4df70f314eee22dc3f7bb266c3f1b295143b0f45 /etc/Makefile.am
parent2df3fabfdc2039504295219c88e0d160f76c1afb (diff)
have 'make dist' build a windows installer on windows
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@826173 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 51a00d26..2ff298ad 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -27,6 +27,10 @@ nobase_sysconf_DATA = $(default_sysconf_data) $(init_sysconf_data)
EXTRA_DIST = $(init_sysconf_data)
+if WINDOWS
+EXTRA_DIST += windows/setup-couchdb-@version@.exe
+endif
+
CLEANFILES = $(init_DATA) $(default_sysconf_data) $(launchd_DATA)
transform = @program_transform_name@
@@ -63,6 +67,38 @@ launchd/org.apache.couchdb.plist: launchd/org.apache.couchdb.plist.tpl
-e "s|%couchdb_command_name%|$(couchdb_command_name)|" \
< $< > $@
+if WINDOWS
+
+# README.txt has \n line endings in the repo and must have \r\n
+# when installed as notepad is used to view it.
+# Also: the targets below don't seem to update after an svn-up (which
+# changes the version string in the generated files) so we trick make
+# into always building it with the FORCE pattern...
+windows/README.txt: windows/README.txt.tpl FORCE
+ sed -e "s|%package_name%|@package_name@|g" \
+ -e "s|%version%|@version@|g" \
+ < $< | unix2dos > $@
+
+windows/couchdb.iss: windows/couchdb.iss.tpl FORCE
+ sed -e "s|%configure_input%|$@. Generated from $< by configure.|" \
+ -e "s|%package_name%|@package_name@|g" \
+ -e "s|%locallibbindir%|`cygpath -m @locallibbindir@`|g" \
+ -e "s|%version%|@version@|g" \
+ -e "s|%openssl_bin_dir%|@openssl_bin_dir@|g" \
+ -e "s|%msvc_redist_dir%|@msvc_redist_dir@|g" \
+ -e "s|%msvc_redist_name%|@msvc_redist_name@|g" \
+ < $< > $@
+
+# The installer depends on all files, not just the source .iss file,
+# so we trick make into always building it with the FORCE pattern...
+windows/setup-couchdb-@version@.exe: windows/couchdb.iss windows/README.txt FORCE
+ $(INNO_COMPILER_EXECUTABLE) /q $<
+ @echo Windows Installer is at: `cygpath -a -w windows/setup-couchdb-@version@.exe`
+
+FORCE:
+
+endif
+
install-data-hook:
if test -n "$(init_DATA)"; then \
chmod +x "$(DESTDIR)$(initdir)/couchdb"; \