summaryrefslogtreecommitdiff
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2008-06-15 16:49:21 +0000
committerNoah Slater <nslater@apache.org>2008-06-15 16:49:21 +0000
commit081daf1250c079efc38a6be9c04984718d441a1f (patch)
treeefd6494e87b1ccbb520426a61187c3b255d35b5b /etc/Makefile.am
parentcd9dd26d15ffa8c0a86d037890d2075d2dafa939 (diff)
removed abspath from makefiles
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@667971 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'etc/Makefile.am')
-rw-r--r--etc/Makefile.am20
1 files changed, 7 insertions, 13 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
index 039ceb44..0126eb30 100644
--- a/etc/Makefile.am
+++ b/etc/Makefile.am
@@ -30,12 +30,6 @@ CLEANFILES = $(init_DATA) $(nobase_sysconf_DATA) $(launchd_DATA)
transform = @program_transform_name@
couchdb_command_name = `echo couchdb | sed '$(transform)'`
-abs_bindir = $(abspath $(bindir))
-abs_localstatedir = $(abspath $(localstatedir))
-abs_sysconfdir = $(abspath $(sysconfdir))
-abs_pkgconfdir = $(abspath $(pkgconfdir))
-abs_erlangbindir = $(abspath $(erlangbindir))
-
default/couchdb: default/couchdb.tpl
if test "$(mkdir_p)"; then \
$(mkdir_p) default; \
@@ -45,9 +39,9 @@ default/couchdb: default/couchdb.tpl
fi \
fi
sed -e "s|%configure_input%|$@. Generated from $< by configure.|" \
- -e "s|%pkgconfdir%|$(abs_pkgconfdir)|g" \
- -e "s|%sysconfdir%|$(abs_sysconfdir)|" \
- -e "s|%localstatedir%|$(abs_localstatedir)|" \
+ -e "s|%pkgconfdir%|$(pkgconfdir)|g" \
+ -e "s|%sysconfdir%|$(sysconfdir)|" \
+ -e "s|%localstatedir%|$(localstatedir)|" \
< $< > $@
init/couchdb: init/couchdb.tpl
@@ -59,9 +53,9 @@ init/couchdb: init/couchdb.tpl
fi \
fi
sed -e "s|%configure_input%|$@. Generated from $< by configure.|" \
- -e "s|%bindir%|$(abs_bindir)|" \
- -e "s|%sysconfdir%|$(abs_sysconfdir)|" \
- -e "s|%erlangbindir%|$(abs_erlangbindir)|" \
+ -e "s|%bindir%|$(bindir)|" \
+ -e "s|%sysconfdir%|$(sysconfdir)|" \
+ -e "s|%erlangbindir%|$(erlangbindir)|" \
-e "s|%couchdb_command_name%|$(couchdb_command_name)|" \
< $< > $@
@@ -77,7 +71,7 @@ launchd/org.apache.couchdb.plist: launchd/org.apache.couchdb.plist.tpl
fi \
fi
sed -e "s|%configure_input%|$@. Generated from $< by configure.|" \
- -e "s|%bindir%|$(abs_bindir)|" \
+ -e "s|%bindir%|$(bindir)|" \
-e "s|%couchdb_command_name%|$(couchdb_command_name)|" \
< $< > $@