summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2008-11-06 12:58:29 +0000
committerJan Lehnardt <jan@apache.org>2008-11-06 12:58:29 +0000
commitf9f5d67681f2fe9321820968c873208b8d8d7e4d (patch)
tree108a831c8f9280480d51fbb4ac603c2c0a759354 /configure.ac
parent60bc407c5fc00acc1d0608a45693b8cc61b21d79 (diff)
Silence warning on Linux by properly exporting `crypt()`.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@711852 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92ca41e4..e3b1b454 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,7 +109,11 @@ AC_SUBST(CURL_CFLAGS)
AC_SUBST(CURL_LIBS)
case "$(uname -s)" in
- Linux | FreeBSD)
+ Linux)
+ LIBS="$LIBS -lcrypt"
+ CPPFLAGS="-D_XOPEN_SOURCE $CPPFLAGS"
+ ;;
+ FreeBSD)
LIBS="$LIBS -lcrypt"
;;
OpenBSD)