summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRandall Leeds <randall@apache.org>2011-10-02 04:11:54 -0700
committerRandall Leeds <randall@apache.org>2011-10-02 04:11:54 -0700
commita378a6a13981b962039c8cd11e11caf0759965bd (patch)
tree351c7609ffc3e07aa8f9c9b62bcd2a178fedac65 /configure.ac
parente77949221f63a011787118637cb549abfbd8e5e8 (diff)
improve argument parsing in couchjs
This change makes argument parsing in couchjs more robust: * Removes the need for couchjs script * Adds long options * Makes all the options to couchjs available (fix COUCHDB-893) Conflicts: bin/Makefile.am bin/couchjs.tpl.in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b5f8697a..5124b8b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,8 @@ dnl WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
dnl License for the specific language governing permissions and limitations
dnl under the License.
-AC_INIT([LOCAL_PACKAGE_NAME], [LOCAL_VERSION], [], [LOCAL_PACKAGE_TARNAME])
+AC_INIT([LOCAL_PACKAGE_NAME], [LOCAL_VERSION], [LOCAL_BUG_URI],
+ [LOCAL_PACKAGE_TARNAME])
AC_PREREQ([2.59])
@@ -339,7 +340,7 @@ AC_ARG_VAR([HELP2MAN_EXECUTABLE], [path to the `help2man' program])
if test -n "$HELP2MAN_EXECUTABLE"; then
help2man_enabled=true
else
- if test -f "$srcdir/bin/couchdb.1" -a -f "$srcdir/bin/couchjs.1"; then
+ if test -f "$srcdir/bin/couchdb.1" -a -f "$srcdir/src/couchdb/priv/couchjs.1"; then
help2man_enabled=true
else
help2man_enabled=false
@@ -389,7 +390,6 @@ AC_SUBST(abs_top_builddir)
AC_REVISION([LOCAL_VERSION])
AC_CONFIG_FILES([Makefile])
-AC_CONFIG_FILES([bin/couchjs.tpl])
AC_CONFIG_FILES([bin/couchdb.tpl])
AC_CONFIG_FILES([bin/couchdb.bat.tpl])
AC_CONFIG_FILES([bin/Makefile])