summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Lehnardt <jan@apache.org>2008-10-23 21:41:37 +0000
committerJan Lehnardt <jan@apache.org>2008-10-23 21:41:37 +0000
commitefe07f99d52d1c5979340e4f79a80abf19b1c710 (patch)
tree7b3ef0904cfaa3b16c4acde9c077ac13d38f5788 /Makefile.am
parentf98d83669bcea9f119e70457cfcc2d765f917857 (diff)
Add `make dev` target. Use `./utils/run` to launch CouchDB from the source tree and without `make install`. Useful for development. Patch my Hunter Morris, thanks! Closes COUCHDB-114.
git-svn-id: https://svn.apache.org/repos/asf/incubator/couchdb/trunk@707480 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 744424f7..3898295b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@
## License for the specific language governing permissions and limitations
## under the License.
-SUBDIRS = bin etc src/couchdb src/mochiweb share test var
+SUBDIRS = bin etc src/couchdb src/mochiweb share test var utils
localdoc_DATA = AUTHORS.gz BUGS.gz CHANGES.gz NEWS.gz README.gz THANKS.gz
@@ -36,6 +36,14 @@ README.gz: $(top_srcdir)/README
THANKS.gz: $(top_srcdir)/THANKS
-gzip -9 < $< > $@
+dev: all
+ @echo "This command is intended for developers to use;"
+ @echo "it creates development ini files as well as a"
+ @echo "$(top_srcdir)/tmp structure for development runtime files"
+ mkdir -p $(top_srcdir)/tmp/lib
+ mkdir -p $(top_srcdir)/tmp/log
+ mkdir -p $(top_srcdir)/tmp/run
+
.PHONY: local-clean
local-clean: maintainer-clean
@echo "This command is intended for maintainers to use;"
@@ -49,6 +57,7 @@ local-clean: maintainer-clean
rm -f $(top_srcdir)/*.tar.gz.*
rm -fr $(top_srcdir)/build-aux
rm -fr $(top_srcdir)/m4
+ rm -fr $(top_srcdir)/tmp
find $(top_srcdir) -name Makefile.in -exec rm {} \;
.PHONY: distsign