summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-09-29 02:38:18 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-09-29 02:38:18 +0000
commite5813d55b0f65d30b3081d0f1a5cd2e7b6f900ed (patch)
tree59bf3af8ae1b074edf286b541eb2cfc550122a0b /Makefile.am
parent09c24441707ad620482a70fb768a117602777091 (diff)
Add ETap to CouchDB's SVN repository.
This pulls in ETap as an included dependency. As per directions of the ASF the NOTICE and LICENSE have been updated. Tests have been updated to include etap on Erlang's code path. license.skip was updated for make distcheck. This only affects running the Erlang test suite. Noah is awesome. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@819799 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e9ead7e..9a42afd4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,7 +10,7 @@
## License for the specific language governing permissions and limitations under
## the License.
-SUBDIRS = bin etc src/couchdb src/erlang-oauth src/ibrowse src/mochiweb share test var utils
+SUBDIRS = bin etc src/couchdb src/erlang-oauth src/etap src/ibrowse src/mochiweb share test var utils
localdoc_DATA = AUTHORS.gz BUGS.gz CHANGES.gz NEWS.gz README.gz THANKS.gz
@@ -43,7 +43,9 @@ cover: dev
rm -f cover/*.coverdata
COVER=1 COVER_BIN=./src/couchdb/ prove test/etap/*.t
SRC=./src/couchdb/ \
- $(ERL) -noshell -eval 'etap_report:create()' \
+ $(ERL) -noshell \
+ -pa src/etap \
+ -eval 'etap_report:create()' \
-s init stop > /dev/null 2>&1
dev: all