summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Joseph Davis <davisp@apache.org>2009-05-30 21:12:06 +0000
committerPaul Joseph Davis <davisp@apache.org>2009-05-30 21:12:06 +0000
commit9e9230c129816dc2ee7092734e72bffb2ac17748 (patch)
tree72c8419ce3bb95d8e38a8388870e9617e6b0a0da /Makefile.am
parent2b4436982461eda62e2e4ee2910663ce2a44c146 (diff)
Added code coverage report generation target.
To generate reports: # Assuming etap is installed $ cd /path/to/couchdb $ ./bootstrap && ERLC_FLAGS=+debug_info ./configure && make cover You can browse the report by opening ./cover/index.html in your html consuming software of choice. Shoutout to Nick Gerakines in THANKS for helping with etap and testing in general. git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@780326 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2e4790d0..5ee69f0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,13 @@ THANKS.gz: $(top_srcdir)/THANKS
check: all
prove test/etap/*.t
+cover: all
+ rm -f cover/*.coverdata
+ COVER=1 COVER_BIN=./src/couchdb/ prove test/etap/*.t
+ SRC=./src/couchdb/ \
+ $(ERL) -noshell -eval 'etap_report:create()' \
+ -s init stop -noshell > /dev/null 2>&1
+
dev: all
@echo "This command is intended for developers to use;"
@echo "it creates development ini files as well as a"