summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNoah Slater <nslater@apache.org>2009-07-14 19:36:12 +0000
committerNoah Slater <nslater@apache.org>2009-07-14 19:36:12 +0000
commit69d1f1d09a68243b4d0ce6e4db869d6b9758c537 (patch)
tree410fb6320ce4f887360bcccc76260bed69f9edaf /Makefile.am
parentd8dee3b9e3b9f182982a97cbd8c3517aa8fcf30f (diff)
added licence check, and licence.skip
git-svn-id: https://svn.apache.org/repos/asf/couchdb/trunk@794030 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ba55310..5a81a6c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,6 +69,11 @@ local-clean: maintainer-clean
rm -fr $(top_srcdir)/tmp
find $(top_srcdir) -name Makefile.in -exec rm {} \;
+distcheck-hook:
+ grep -rL 'http://www.apache.org/licenses/LICENSE-2.0' * \
+ | grep -vf licence.skip; \
+ test "$$?" -eq 1
+
.PHONY: distsign
distsign: distcheck
gpg --armor --detach-sig \