summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMicah Anderson <micah@leap.se>2014-01-17 08:43:45 -0200
committerdrebs <drebs@leap.se>2014-01-17 08:48:12 -0200
commitd345da23681293a625f58dcc9303131527b70a32 (patch)
tree0ca0a4c47729919123190f85694671681b4106f0
parent510c6d763fba74f95ae8f894408c3658bcef4f83 (diff)
Hard code version so we don't need git when packaging.
-rw-r--r--Makefile2
-rw-r--r--couchjs/c_src/SConscript2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ef6236cd..49772504 100644
--- a/Makefile
+++ b/Makefile
@@ -19,7 +19,7 @@ compile:
@echo "==> couchjs (compile)"
@cd couchjs && python scons/scons.py
@./rebar compile
- @cat $(appfile) | sed s/%VSN%/`git describe --match 1.*`/ > $(appfile)
+ @cat $(appfile) | sed s/%VSN%/`echo 1.1.1-792-gc8a44ff`/ > $(appfile)
clean:
@echo "==> couchjs (clean)"
diff --git a/couchjs/c_src/SConscript b/couchjs/c_src/SConscript
index 68ad5d3e..c0cc4a1f 100644
--- a/couchjs/c_src/SConscript
+++ b/couchjs/c_src/SConscript
@@ -105,7 +105,7 @@ if not env.GetOption('clean'):
## Define properties for -h / -V
- (_, vsn) = runcmd("git describe --match 1.*")
+ vsn = "1.1.1-792-gc8a44ff"
conf.Define("PACKAGE_STRING", '"%s"' % vsn.rstrip())
conf.Define("PACKAGE_NAME", '"Cloudant BigCouch"')
conf.Define("PACKAGE_BUGREPORT", '"https://github.com/cloudant/bigcouch/issues"')