summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Newson <rnewson@apache.org>2011-09-27 23:11:24 +0000
committerRobert Newson <rnewson@apache.org>2011-09-27 23:11:24 +0000
commitb707a67d13060ef9723cd685280b4e47f71c2ac6 (patch)
tree7cfc33c22d3297d6345f75c78221d651177981d5
parentbefbdfb11f45bd2a5ccffb6b0d5ac04435ac9e55 (diff)
Fixes COUCHDB-1152 - Update ICU on Windows.
Thanks to Dave Cottlehuber for the patch. git-svn-id: https://svn.apache.org/repos/asf/couchdb/branches/1.1.x@1176651 13f79535-47bb-0310-9956-ffa450edef68
-rw-r--r--INSTALL.Windows6
-rw-r--r--src/couchdb/priv/Makefile.am6
2 files changed, 6 insertions, 6 deletions
diff --git a/INSTALL.Windows b/INSTALL.Windows
index d2082734..d661f1da 100644
--- a/INSTALL.Windows
+++ b/INSTALL.Windows
@@ -8,8 +8,8 @@ Dependencies
You will need the following installed:
- * Erlang OTP (=14B01) (http://erlang.org/)
- * ICU (http://icu.sourceforge.net/)
+ * Erlang OTP (>=14B03) (http://erlang.org/)
+ * ICU (=4.4.*) (http://icu.sourceforge.net/)
* OpenSSL (http://www.openssl.org/)
* Mozilla SpiderMonkey (1.8) (http://www.mozilla.org/js/spidermonkey/)
* libcurl (http://curl.haxx.se/libcurl/)
@@ -21,7 +21,7 @@ General Notes
* When installing Erlang, you must build it from source.
- The CouchDB build makes use of a number of the Erlang build scripts.
+The CouchDB build requires a number of the Erlang build scripts.
* When installing ICU, select the binaries built with Visual Studio 2008.
diff --git a/src/couchdb/priv/Makefile.am b/src/couchdb/priv/Makefile.am
index 3d11e663..4a32c0a2 100644
--- a/src/couchdb/priv/Makefile.am
+++ b/src/couchdb/priv/Makefile.am
@@ -84,9 +84,9 @@ install-data-hook:
$(LN_S) couch_icu_driver couch_icu_driver.so; \
fi
if WINDOWS
- $(INSTALL) $(ICU_LOCAL_BIN)/icuuc42.dll $(bindir)
- $(INSTALL) $(ICU_LOCAL_BIN)/icudt42.dll $(bindir)
- $(INSTALL) $(ICU_LOCAL_BIN)/icuin42.dll $(bindir)
+ $(INSTALL) $(ICU_LOCAL_BIN)/icuuc44.dll $(bindir)
+ $(INSTALL) $(ICU_LOCAL_BIN)/icudt44.dll $(bindir)
+ $(INSTALL) $(ICU_LOCAL_BIN)/icuin44.dll $(bindir)
$(INSTALL) $(JS_LIB_BINARY) $(bindir)
$(INSTALL) .libs/couchspawnkillable.exe \
"$(DESTDIR)$(couchprivdir)/couchspawnkillable.exe"