summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rwxr-xr-xMakefile40
-rw-r--r--debian/changelog12
-rw-r--r--debian/compat1
-rw-r--r--debian/control26
-rw-r--r--debian/copyright18
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/source/format1
-rw-r--r--install.rdf.template24
9 files changed, 113 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
index b5c010c..c24abca 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
build/
dot-thunderbird/
install.rdf
+*.xpi
diff --git a/Makefile b/Makefile
index d331e5b..0bcdba1 100755
--- a/Makefile
+++ b/Makefile
@@ -7,7 +7,11 @@ RSA_FILE := META-INF/zigbert.rsa
COMMIT := $(shell git --no-pager log -1 --format=format:%h)
VERSION = $(shell head -n1 CHANGELOG | cut -d" " -f1)
PKGNAME := $(EXTNAME)-$(VERSION)-$(COMMIT).xpi
-TARGET := $(CURDIR)/build/$(PKGNAME)
+# XXX for debian makefile it's simpler to pick a fixed name.
+# XXX we could build it and rename in another goal.
+XPINAME := bitmask.xpi
+TARGET := $(CURDIR)/$(XPINAME)
+#TARGET := $(CURDIR)/build/$(PKGNAME)
TEMPDIR := $(shell mktemp -d -u)
# make sure CERTDIR and CERTNAME are defined for signing
@@ -27,15 +31,32 @@ endif
# make sure DEFAULTKEY was given to sign the calculated hashes
ifneq ($(MAKECMDGOALS),clean)
ifneq ($(MAKECMDGOALS),upload)
+ifneq ($(MAKECMDGOALS),bitmask.xpi)
+ifneq ($(MAKECMDGOALS),install.rdf)
ifndef DEFAULTKEY
- $(error "Usage: make DEFAULTKEY=<key id>")
+# XXX need to remove signed from default build, debian chokes otherwise
+# $(error "Usage: make DEFAULTKEY=<key id>")
endif
endif
endif
+endif
+endif
+
+XPI_CONTENTS:=$(shell find chrome -name "*.html" -o -name "*.xhtml" -o -name "*.css" -o -name "*.png" -o -name "*.gif" -o -name "*.js" -o -name "*.jsm" -o -name "*.dtd" -o -name "*.xul" -o -name "messages") chrome.manifest install.rdf COPYING
+
+bitmask.xpi: $(XPI_CONTENTS)
+ zip $@ $(XPI_CONTENTS)
+
+install.rdf: install.rdf.template Changelog
+ sed 's/__VERSION__/$(VERSION)/' < $< > $@
+
+xpi_release:
+ ln -s $(XPINAME) $(PKGNAME)
+
# main rule
-all: clean $(TARGET)
+#all: clean $(TARGET)
# main target: .xpi file
@@ -54,7 +75,7 @@ signed: clean
cp -r $(PREFIX)/{$(FILES_TO_PACKAGE)} $(TEMPDIR)/
rm -rf $(TEMPDIR)/.gitignore
signtool -d $(CERTDIR) -k $(CERTNAME) $(TEMPDIR)/
- (cd $(TEMPDIR) && zip $(TARGET) ./$(RSA_FILE) && zip -r -D $(TARGET) ./ -x ./$(RSA_FILE))
+ (cd $(TEMPDIR) && zip $(TARGET) ./$(RSA_FILE) && zip -D $@ $(XPI_CONTENTS) -x ./$(RSA_FILE))
rm -rf $(TEMPDIR)
(cd build/ && sha512sum $(PKGNAME) > SHA512SUMS && gpg -a --default-key $(DEFAULTKEY) --detach-sign SHA512SUMS)
@@ -72,4 +93,13 @@ debian-package:
install.rdf: install.rdf.template Changelog
sed 's/__VERSION__/$(VERSION)/' < $< > $@
-.PHONY: all clean signed
+debian-package:
+ git buildpackage -us -uc
+
+clean:
+ #rm -f $(TARGET) build/*
+ rm -f *.xpi
+ rm -f install.rdf
+
+
+.PHONY: all clean
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..e233f17
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,12 @@
+xul-ext-bitmask (0.0.3) unstable; urgency=low
+
+ * Update to 0.0.3 release.
+
+ -- Ben Carrillo <ben@futeisha.org> Mon, 23 Dec 2013 16:38:31 -0400
+
+xul-ext-bitmask (0.0.1) unstable; urgency=low
+
+ * Initial release. (Closes: #XXXXXX)
+
+ -- Ben Carrillo <ben@futeisha.org> Fri, 11 Oct 2013 12:49:30 -0300
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..80b4e34
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,26 @@
+Source: xul-ext-bitmask
+Section: web
+Priority: optional
+Maintainer: Ben Carrillo <ben@futeisha.org>
+Uploaders: Micah Anderson <mica@debian.org>
+Standards-Version: 3.9.4
+Build-Depends: debhelper (>= 9~),
+ mozilla-devscripts (>= 0.19~)
+Homepage: https://github.com/leapcode/thunderbird_extension
+
+Package: xul-ext-bitmask
+Architecture: all
+Depends: ${misc:Depends}, ${xpi:Depends}, icedove (>= 24.0~b1)
+Recommends: ${xpi:Recommends},
+ bitmask
+Provides: ${xpi:Provides}
+Enhances: ${xpi:Enhances}
+Breaks: ${xpi:Breaks}
+Description: Automatic configuration for Bitmask encrypted mail accounts
+ Bitmask is a desktop client that provides easy-to-use Encrypted Email and
+ Encrypted Internet Proxy services.
+ .
+ This extensions provides a wizard for autoconfiguring Thunderbird with Bitmask
+ accounts. It will try to use the default ports used by the SMTP and IMAP
+ services offered by the Bitmask client. It also turns off caching and prevents
+ users from modifying this setting to protect privacy.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..2b4d20f
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,18 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: Bitmask Thunderbird Extension
+Source: https://github.com/leapcode/thunderbird_extension
+Upstream-Contact: drebs <drebs@leap.se>
+
+Files: *
+Copyright: 2013 The LEAP Encryption Access Project <info@leap.se>,
+ drebs <drebs@leap.se>
+License: GPL-3+
+
+License: GPL-3+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+ .
+ On Debian systems, the complete text of the GNU General Public License
+ version 3 can be found in file "/usr/share/common-licenses/GPL-3".
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ef0822e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,6 @@
+#!/usr/bin/make -f
+%:
+ dh $@ --with xul-ext
+
+override_dh_auto_install:
+ install-xpi -x COPYING bitmask.xpi
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/install.rdf.template b/install.rdf.template
index e447a3e..c851909 100644
--- a/install.rdf.template
+++ b/install.rdf.template
@@ -25,37 +25,39 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
<em:id>bitmask-thunderbird@leap.se</em:id>
<em:name>Bitmask Thunderbird Extension</em:name>
<em:version>__VERSION__</em:version>
+ <em:type>2</em:type>
+ <em:description>Automatic configuration for Bitmask Encrypted Mail accounts.
+ </em:description>
<em:creator>LEAP developers</em:creator>
- <em:type>2</em:type> <!-- type=extension -->
+ <em:contributor>Andre Jucovsky Bianchi
+ </em:contributor>
+ <em:homepageURL>https://github.com/leapcode/thunderbird_extension/</em:homepageURL>
+ <em:iconURL>chrome://bitmask/content/logo-small.png</em:iconURL>
<em:targetApplication>
<Description>
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
- <em:minVersion>24.0</em:minVersion>
- <em:maxVersion>24.*</em:maxVersion>
+ <em:minVersion>23.999</em:minVersion>
+ <em:maxVersion>24.0.*</em:maxVersion>
</Description>
</em:targetApplication>
- <!-- here is an example for future localizations ;
- em: name, em:description, em:creator
- should probably be overridden -->
<em:localized>
<Description>
<em:locale>en-US</em:locale>
<em:name>Bitmask</em:name>
- <em:description>Configure Bitmask encrypted mail accounts.
+ <em:description>Configure Bitmask Encrypted Mail accounts.
</em:description>
<em:creator>The LEAP Encryption Access Project</em:creator>
</Description>
- </em:localized>
+ </em:localized>
<em:localized>
<Description>
<em:locale>es-ES</em:locale>
<em:name>Bitmask</em:name>
- <em:description>Configura cuentas Bitmask de correo cifrado.
+ <em:description>Configura cuentas Bitmask de Correo Cifrado.
</em:description>
<em:creator>El projecto LEAP, Encryption Access Project</em:creator>
</Description>
- </em:localized>
-
+ </em:localized>
</Description>
</RDF>