summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKali Kaneko <kali@futeisha.org>2013-12-23 16:43:25 -0400
committerKali Kaneko <kali@futeisha.org>2013-12-23 16:43:25 -0400
commit563ccb3638e594668d3ea57ea7a37fa228541417 (patch)
treec6320b7d0f755551f32792caed061236df0f0f2d
parent8ab72718a95a5b10881943c9b7a13d955ce390c6 (diff)
parent7f851488dbc8fe70924432c279488e31b662f854 (diff)
Merge tag '0.0.3' into debian
Tag bitmask_thunderbird 0.0.3 Conflicts: .gitignore Makefile install.rdf.template
-rw-r--r--CHANGELOG8
-rwxr-xr-xMakefile34
-rw-r--r--chrome/content/.gitignore1
-rw-r--r--chrome/content/accountWizard/accountWizard.js38
-rw-r--r--chrome/content/accountWizard/accountWizard.xul12
-rw-r--r--chrome/content/logo-small.pngbin0 -> 3050 bytes
-rw-r--r--chrome/content/logo.pngbin0 -> 13810 bytes
-rw-r--r--chrome/locale/en-US/accountWizard.properties2
-rw-r--r--install.rdf.template1
9 files changed, 60 insertions, 36 deletions
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 0000000..d8e3811
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,8 @@
+0.0.3 Dez 23:
+ o Remove the password field from the account wizard. Closes #4525.
+ o Remove misleading encryption information from wizard (#4545).
+0.0.2 Nov 5:
+ o Fix items from Mozilla editors review. Closes #4374.
+ o Create a Thunderbird extension with a wizard for creating LEAP's Bitmask
+ client-compliant accounts and with caching prevention. Closes #3542.
+
diff --git a/Makefile b/Makefile
index 89b3de1..0bcdba1 100755
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ RSA_FILE := META-INF/zigbert.rsa
# the following variables are updated automatically
COMMIT := $(shell git --no-pager log -1 --format=format:%h)
-VERSION = $(shell head -n1 Changelog | sed -e 's/^.*(//' -e 's/).*$$//')
+VERSION = $(shell head -n1 CHANGELOG | cut -d" " -f1)
PKGNAME := $(EXTNAME)-$(VERSION)-$(COMMIT).xpi
# XXX for debian makefile it's simpler to pick a fixed name.
# XXX we could build it and rename in another goal.
@@ -54,28 +54,44 @@ xpi_release:
ln -s $(XPINAME) $(PKGNAME)
+
# main rule
#all: clean $(TARGET)
# main target: .xpi file
-#$(TARGET):
-# mkdir -p $(TEMPDIR)
-# cp -r $(PREFIX)/{$(FILES_TO_PACKAGE)} $(TEMPDIR)/
-# (cd $(TEMPDIR) && zip $@ $(XPI_CONTENTS))
-# rm -rf $(TEMPDIR)
-# (cd build/ && sha512sum $(PKGNAME) > SHA512SUMS && gpg --default-key $(DEFAULTKEY) --sign SHA512SUMS)
+$(TARGET): clean install.rdf
+ mkdir -p $(TEMPDIR)
+ mkdir -p `dirname $@`
+ cp -r $(PREFIX)/{$(FILES_TO_PACKAGE)} $(TEMPDIR)/
+ rm -rf $(TEMPDIR)/.gitignore
+ (cd $(TEMPDIR) && zip -r $(TARGET) ./)
+ rm -rf $(TEMPDIR)
+ (cd build/ && sha512sum $(PKGNAME) > SHA512SUMS && gpg -a --default-key $(DEFAULTKEY) --detach-sign SHA512SUMS)
signed: clean
mkdir -p $(TEMPDIR)
+ mkdir -p `dirname $@`
cp -r $(PREFIX)/{$(FILES_TO_PACKAGE)} $(TEMPDIR)/
+ rm -rf $(TEMPDIR)/.gitignore
signtool -d $(CERTDIR) -k $(CERTNAME) $(TEMPDIR)/
(cd $(TEMPDIR) && zip $(TARGET) ./$(RSA_FILE) && zip -D $@ $(XPI_CONTENTS) -x ./$(RSA_FILE))
rm -rf $(TEMPDIR)
- (cd build/ && sha512sum $(PKGNAME) > SHA512SUMS && gpg --default-key $(DEFAULTKEY) --sign SHA512SUMS)
+ (cd build/ && sha512sum $(PKGNAME) > SHA512SUMS && gpg -a --default-key $(DEFAULTKEY) --detach-sign SHA512SUMS)
+
+clean:
+ rm -f $(TARGET) build/*
+ rm -f install.rdf
upload:
- scp build/* downloads.leap.se:~/public/thunderbird_extension/
+ ssh downloads.leap.se rm -rf /var/www/leap-downloads/public/thunderbird_extension/*
+ scp build/* downloads.leap.se:/var/www/leap-downloads/public/thunderbird_extension/
+
+debian-package:
+ git buildpackage -us -uc
+
+install.rdf: install.rdf.template Changelog
+ sed 's/__VERSION__/$(VERSION)/' < $< > $@
debian-package:
git buildpackage -us -uc
diff --git a/chrome/content/.gitignore b/chrome/content/.gitignore
deleted file mode 100644
index 3fec32c..0000000
--- a/chrome/content/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-tmp/
diff --git a/chrome/content/accountWizard/accountWizard.js b/chrome/content/accountWizard/accountWizard.js
index b2b533f..35dae00 100644
--- a/chrome/content/accountWizard/accountWizard.js
+++ b/chrome/content/accountWizard/accountWizard.js
@@ -28,7 +28,7 @@ Cu.import("resource:///modules/gloda/log4moz.js");
let gEmailWizardLogger = Log4Moz.getConfiguredLogger("mail.wizard");
var gStringsBundle;
-var gMessengerBundle;
+var gAccountWizardStringsBundle;
var gBrandShortName;
function e(elementID)
@@ -111,7 +111,7 @@ BitmaskAccountWizard.prototype =
this._email = "";
this._realname = (userFullname) ? userFullname : "";
e("realname").value = this._realname;
- this._password = "";
+ this._password = "123"; // use any password for now
this._okCallback = null;
if (window.arguments && window.arguments[0]) {
@@ -125,16 +125,17 @@ BitmaskAccountWizard.prototype =
gEmailWizardLogger.info("Email account setup dialog loaded.");
- gStringsBundle = e("strings");
- gMessengerBundle = e("bundle_messenger");
+ gStringsBundle = e("accountCreationStrings");
+ gAccountWizardStringsBundle = e("accountWizardStrings");
gBrandShortName = e("bundle_brand").getString("brandShortName");
// admin-locked prefs hurray
- if (!Services.prefs.getBoolPref("signon.rememberSignons")) {
- let rememberPasswordE = e("remember_password");
- rememberPasswordE.checked = false;
- rememberPasswordE.disabled = true;
- }
+ // we do not use password for now
+ //if (!Services.prefs.getBoolPref("signon.rememberSignons")) {
+ // let rememberPasswordE = e("remember_password");
+ // rememberPasswordE.checked = false;
+ // rememberPasswordE.disabled = true;
+ //}
// First, unhide the main window areas, and store the width,
// so that we don't resize wildly when we unhide areas.
@@ -205,8 +206,9 @@ BitmaskAccountWizard.prototype =
{
var result = this._currentConfig.copy();
replaceVariables(result, this._realname, this._email, this._password);
- result.rememberPassword = e("remember_password").checked &&
- !!this._password;
+ //result.rememberPassword = e("remember_password").checked &&
+ // !!this._password;
+ result.rememberPassword = true;
return result;
},
@@ -463,13 +465,13 @@ BitmaskAccountWizard.prototype =
unknownString);
let host = server.hostname +
(isStandardPort(server.port) ? "" : ":" + server.port);
- let ssl = gStringsBundle.getString(sanitize.translate(server.socketType,
- { 1 : "resultNoEncryption", 2 : "resultSSL", 3 : "resultSTARTTLS" }),
- unknownString);
- let certStatus = gStringsBundle.getString(server.badCert ?
- "resultSSLCertWeak" : "resultSSLCertOK");
- return gStringsBundle.getFormattedString(stringName,
- [ type, host, ssl, certStatus ]);
+ //let ssl = gStringsBundle.getString(sanitize.translate(server.socketType,
+ // { 1 : "resultNoEncryption", 2 : "resultSSL", 3 : "resultSTARTTLS" }),
+ // unknownString);
+ //let certStatus = gStringsBundle.getString(server.badCert ?
+ // "resultSSLCertWeak" : "resultSSLCertOK");
+ return gAccountWizardStringsBundle.getFormattedString(stringName,
+ [ type, host ]);
};
var incomingResult = unknownString;
diff --git a/chrome/content/accountWizard/accountWizard.xul b/chrome/content/accountWizard/accountWizard.xul
index 0d42c0d..1587c50 100644
--- a/chrome/content/accountWizard/accountWizard.xul
+++ b/chrome/content/accountWizard/accountWizard.xul
@@ -31,12 +31,10 @@
<stringbundleset>
<stringbundle id="bundle_brand"
src="chrome://branding/locale/brand.properties"/>
- <stringbundle id="strings"
+ <stringbundle id="accountCreationStrings"
src="chrome://messenger/locale/accountCreation.properties"/>
- <stringbundle id="utilstrings"
- src="chrome://messenger/locale/accountCreationUtil.properties"/>
- <stringbundle id="bundle_messenger"
- src="chrome://messenger/locale/messenger.properties"/>
+ <stringbundle id="accountWizardStrings"
+ src="chrome://bitmask/locale/accountWizard.properties"/>
</stringbundleset>
<script type="application/javascript"
src="chrome://bitmask/content/serverConfig.js"/>
@@ -112,9 +110,8 @@
<description id="emailerror" class="errordescription" hidden="true"/>
</hbox>
</row>
+ <!-- we do not use the password for now.
<row align="center">
- <!-- this starts out as text so the emptytext shows, but then
- changes to type=password once it's not empty -->
<label accesskey="&password.accesskey;"
class="autoconfigLabel"
value="&password.label;"
@@ -141,6 +138,7 @@
accesskey="&rememberPassword.accesskey;"
checked="true"/>
</row>
+ -->
</rows>
</grid>
<spacer flex="1" />
diff --git a/chrome/content/logo-small.png b/chrome/content/logo-small.png
new file mode 100644
index 0000000..0f29cd1
--- /dev/null
+++ b/chrome/content/logo-small.png
Binary files differ
diff --git a/chrome/content/logo.png b/chrome/content/logo.png
new file mode 100644
index 0000000..fdb2be0
--- /dev/null
+++ b/chrome/content/logo.png
Binary files differ
diff --git a/chrome/locale/en-US/accountWizard.properties b/chrome/locale/en-US/accountWizard.properties
index 51532d0..f91fc70 100644
--- a/chrome/locale/en-US/accountWizard.properties
+++ b/chrome/locale/en-US/accountWizard.properties
@@ -1,2 +1,4 @@
# verifyConfig.js
cannot_login.error=Unable to log in at server. Probably wrong configuration, username or password.
+resultIncoming=%1$S, %2$S
+resultOutgoing=%1$S, %2$S
diff --git a/install.rdf.template b/install.rdf.template
index cfb9801..c851909 100644
--- a/install.rdf.template
+++ b/install.rdf.template
@@ -59,6 +59,5 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
<em:creator>El projecto LEAP, Encryption Access Project</em:creator>
</Description>
</em:localized>
-
</Description>
</RDF>