summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 19 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index c4d3e8e6..8463c172 100755
--- a/setup.py
+++ b/setup.py
@@ -57,14 +57,13 @@ setup_root = os.path.dirname(__file__)
sys.path.insert(0, os.path.join(setup_root, "src"))
trove_classifiers = [
- "Development Status :: 3 - Alpha",
+ "Development Status :: 4 - Beta",
"Environment :: X11 Applications :: Qt",
"Intended Audience :: End Users/Desktop",
("License :: OSI Approved :: GNU General "
"Public License v3 or later (GPLv3+)"),
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Topic :: Security",
'Topic :: Security :: Cryptography',
@@ -276,7 +275,6 @@ class cmd_build(versioneer_build):
copy_reqs(self.build_lib)
-
class cmd_sdist(versioneer_sdist):
user_options = versioneer_sdist.user_options + \
@@ -300,14 +298,20 @@ class cmd_sdist(versioneer_sdist):
# We need to copy the requirements to the specified path
# so that the client has a copy to do the startup checks.
copy_reqs(base_dir, withsrc=True)
- with open(os.path.join(base_dir,
- 'src', 'leap', '__init__.py'),
- 'w') as nuke_top_init:
- nuke_top_init.write('')
- with open(os.path.join(base_dir,
- 'src', 'leap', 'soledad', '__init__.py'),
- 'w') as nuke_soledad_ns:
- nuke_soledad_ns.write('')
+ try:
+ with open(os.path.join(base_dir,
+ 'src', 'leap', '__init__.py'),
+ 'w') as nuke_top_init:
+ nuke_top_init.write('')
+ except Exception:
+ pass
+ try:
+ with open(os.path.join(base_dir,
+ 'src', 'leap', 'soledad', '__init__.py'),
+ 'w') as nuke_soledad_ns:
+ nuke_soledad_ns.write('')
+ except Exception:
+ pass
def make_distribution(self):
# add our extra files to the list just before building the
@@ -361,7 +365,10 @@ class cmd_sdist(versioneer_sdist):
for module in self.leap_sumo_packages:
# check, just in case...
if module and module != "bitmask":
- shutil.rmtree("src/leap/" + _fix_namespace(module))
+ try:
+ shutil.rmtree("src/leap/" + _fix_namespace(module))
+ except Exception:
+ pass
import shutil