summaryrefslogtreecommitdiff
path: root/pkg
diff options
context:
space:
mode:
Diffstat (limited to 'pkg')
-rw-r--r--[-rwxr-xr-x]pkg/linux/bitmask-root0
-rw-r--r--pkg/pyinst/bitmask.spec.orig38
-rw-r--r--pkg/requirements.pip6
3 files changed, 3 insertions, 41 deletions
diff --git a/pkg/linux/bitmask-root b/pkg/linux/bitmask-root
index 80ac12e8..80ac12e8 100755..100644
--- a/pkg/linux/bitmask-root
+++ b/pkg/linux/bitmask-root
diff --git a/pkg/pyinst/bitmask.spec.orig b/pkg/pyinst/bitmask.spec.orig
deleted file mode 100644
index 617104b9..00000000
--- a/pkg/pyinst/bitmask.spec.orig
+++ /dev/null
@@ -1,38 +0,0 @@
-# -*- mode: python -*-
-
-block_cipher = None
-
-
-a = Analysis([os.path.join('bitmask.py')],
- hiddenimports=[
- 'zope.interface', 'zope.proxy',
- 'PySide.QtCore', 'PySide.QtGui'],
- hookspath=None,
- runtime_hooks=None,
- excludes=None,
- cipher=block_cipher)
-pyz = PYZ(a.pure,
- cipher=block_cipher)
-exe = EXE(pyz,
- a.scripts,
- exclude_binaries=True,
- name='bitmask',
- debug=False,
- strip=False,
- upx=True,
- console=False )
-coll = COLLECT(exe,
- a.binaries,
- a.zipfiles,
- a.datas,
- strip=False,
- upx=True,
- name='bitmask')
-if sys.platform.startswith("darwin"):
- app = BUNDLE(coll,
- name=os.path.join(
- 'dist', 'Bitmask.app'),
- appname='Bitmask',
- version='0.9.0rc2',
- icon='pkg/osx/bitmask.icns',
- bundle_identifier='bitmask-0.9.0rc2')
diff --git a/pkg/requirements.pip b/pkg/requirements.pip
index a5d9f2a0..b86346d0 100644
--- a/pkg/requirements.pip
+++ b/pkg/requirements.pip
@@ -9,13 +9,13 @@ argparse
requests>=1.1.0
srp>=1.0.2
pyopenssl
-coloredlogs
+#coloredlogs
psutil
ipaddr
-twisted
-python-daemon==1.6.1 # this should not be needed for Windows.
+#twisted # removed for debian package
+python-daemon # this should not be needed for Windows.
keyring
zope.proxy