summaryrefslogtreecommitdiff
path: root/pkg/pyinst/pyinst-build.mk
diff options
context:
space:
mode:
Diffstat (limited to 'pkg/pyinst/pyinst-build.mk')
-rw-r--r--pkg/pyinst/pyinst-build.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkg/pyinst/pyinst-build.mk b/pkg/pyinst/pyinst-build.mk
index 16737ead..348395cc 100644
--- a/pkg/pyinst/pyinst-build.mk
+++ b/pkg/pyinst/pyinst-build.mk
@@ -3,7 +3,11 @@ freeze-ver:
sed -i 's/^version_version\(.*\)/version_version = "$(NEXT_VERSION)"/' src/leap/bitmask/_version.py
sed -i 's/^full_revisionid\(.*\)/full_revisionid = "$(GIT_COMMIT)"/' src/leap/bitmask/_version.py
-pyinst: freeze-ver
+hash-binaries:
+ # TODO get from a build dir
+ OPENVPN_BIN=/usr/sbin/openvpn BITMASK_ROOT=pkg/linux/bitmask-root python setup.py hash_binaries
+
+pyinst: freeze-ver hash-binaries
pyinstaller -y pkg/pyinst/bitmask.spec
reset-ver: