summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/bitmask-cli.install3
-rw-r--r--debian/bitmask-core.install2
-rw-r--r--debian/bitmask.install4
-rw-r--r--debian/bitmask.pyremove2
-rw-r--r--debian/control36
-rw-r--r--debian/pydist-overrides2
-rwxr-xr-xdebian/rules24
-rw-r--r--debian/source/include-binaries1
8 files changed, 56 insertions, 18 deletions
diff --git a/debian/bitmask-cli.install b/debian/bitmask-cli.install
new file mode 100644
index 00000000..69703ed7
--- /dev/null
+++ b/debian/bitmask-cli.install
@@ -0,0 +1,3 @@
+/usr/bin/bitmask_cli
+src/leap/bitmask/cli usr/lib/python2.7/dist-packages/leap/bitmask/
+
diff --git a/debian/bitmask-core.install b/debian/bitmask-core.install
new file mode 100644
index 00000000..51161af3
--- /dev/null
+++ b/debian/bitmask-core.install
@@ -0,0 +1,2 @@
+/usr/bin/bitmaskd
+src/leap/bitmask/core usr/lib/python2.7/dist-packages/leap/bitmask/
diff --git a/debian/bitmask.install b/debian/bitmask.install
index 34943e9b..fb081d1e 100644
--- a/debian/bitmask.install
+++ b/debian/bitmask.install
@@ -1,8 +1,11 @@
+/usr/bin/bitmask
+/usr/lib/python2.7/dist-packages/leap.bitmask-*.egg-info
pkg/linux/bitmask-root usr/sbin/
pkg/linux/polkit/se.leap.bitmask.policy usr/share/polkit-1/actions/
debian/bitmask.xpm usr/share/pixmaps
debian/bitmask.desktop usr/share/applications
debian/icons/hicolor usr/share/icons
+src/leap/bitmask usr/lib/python2.7/dist-packages/leap/
# pixelated hacks!!!
src/pixelated usr/lib/python2.7/dist-packages/
@@ -11,3 +14,4 @@ src/leap/bitmask/auth/auth.py usr/lib/python2.7/dist-packages/leap/
src/leap/bitmask/auth/exceptions.py usr/lib/python2.7/dist-packages/leap/
src/leap/bitmask/auth/srp_session.py usr/lib/python2.7/dist-packages/leap/
+
diff --git a/debian/bitmask.pyremove b/debian/bitmask.pyremove
index 702c93f5..9d6e34d3 100644
--- a/debian/bitmask.pyremove
+++ b/debian/bitmask.pyremove
@@ -1 +1,3 @@
usr/etc/leap
+usr/bin/bitmaskd
+usr/bin/bitmask_cli
diff --git a/debian/control b/debian/control
index 52952943..4975fadd 100644
--- a/debian/control
+++ b/debian/control
@@ -7,19 +7,17 @@ Uploaders: Micah Anderson <micah@debian.org>
Homepage: https://leap.se
Build-Depends: debhelper (>= 8.0.0), dh-python, python (>=2.6), python-setuptools,
pep8,
- python-sphinx (>= 1.0.7+dfsg), docutils-common, python-nose, python-mock,
- python-requests (>= 1.2.3), python-srp, python-crypto, python-keyring, python-xdg,
+ python-sphinx (>= 1.0.7+dfsg), docutils-common, python-nose,
+ python-requests (>= 1.2.3), python-srp, python-keyring,
python-jsonschema (>= 0.7.0), python-psutil, python-openssl,
- python-dateutil, python-argparse, pyside-tools,
- xvfb, xauth
-X-Python-Version: >= 2.6
+ python-dateutil, python-argparse, pyside-tools, xvfb, xauth
+X-Python-Version: >= 2.7
Package: bitmask
Architecture: all
Depends:
${misc:Depends}, ${python:Depends},
python-openssl,
- python-crypto,
python-keyring (>= 0.9.2),
python-srp,
python-dateutil,
@@ -38,9 +36,10 @@ Depends:
python-pyside.qtcore,
python-pyside.qtgui,
python-pyside.qtsvg,
+ python-pyside.qtwebkit,
python-twisted-core (>= 14.0.2),
python-leap-common,
- leap-mail (>= 0.3.99),
+ leap-mail (>= 0.4.1),
soledad-client,
# This is a workaround to broken python-srp in wily.
# We should remove libssl-dev when #7566 is solved
@@ -65,4 +64,27 @@ Description: Provides the desktop client for LEAP
encrypted when possible; and public keys are automatically discovered and
validated.
+Package: bitmask-core
+Architecture: all
+Depends: python-twisted-core,
+ python-zope.interface
+Suggests: bitmask-cli
+Provides: leap.bitmask.core, ${python:Provides}
+# Replaces: ...
+# Breaks: ...
+Description: Desktop client to access LEAP Services.
+ The LEAP project aims to secure everyday communication.
+ .
+ This package provides the core daemon.
+
+Package: bitmask-cli
+Architecture: all
+Depends: bitmask-core
+Provides: leap.bitmask.cli, ${python:Provides}
+# Replaces: ...
+# Breaks: ...
+Description: Desktop client to access LEAP Services.
+ The LEAP project aims to secure everyday communication.
+ .
+ This package provides the command line client.
diff --git a/debian/pydist-overrides b/debian/pydist-overrides
index 8380915c..4c1c3c7e 100644
--- a/debian/pydist-overrides
+++ b/debian/pydist-overrides
@@ -2,3 +2,5 @@ leap.soledad.client soledad-client ; PEP386
leap.common python-leap-common ; PEP386
leap.mail leap-mail ; PEP386
leap.keymanager leap-keymanager
+leap.bitmask bitmask
+leap.bitmask-core bitmask-core
diff --git a/debian/rules b/debian/rules
index d82b9451..f762cb3c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@
# This special exception was added by Craig Small in version 0.37 of dh-make.
#
# Uncomment this to turn on verbose mode.
-#DH_VERBOSE=1
+DH_VERBOSE=1
DEB_BUILD_OPTIONS=nocheck
package=bitmask
@@ -22,6 +22,8 @@ override_dh_prep:
rst2man docs/man/bitmask-root.1.rst docs/man/bitmask-root.1
dh_prep
+ mv src/leap.bitmask.egg-info src/leap.bitmask.egg-info.orig
+
# this will re-generate the resource files and locales.
make -f ./Makefile
@@ -30,8 +32,8 @@ ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
#
-test-python%:
- xvfb-run ./run_tests.sh -x -N
+#test-python%:
+# xvfb-run ./run_tests.sh -x -N
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
@@ -41,14 +43,13 @@ endif
build-python%:
python$* setup.py build
-#override_dh_auto_build: $(PYTHON3:%=build-python%)
-# dh_auto_build
-
-install-python%:
- python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
+override_dh_auto_build: $(PYTHON3:%=build-python%)
+ dh_auto_build
-#override_dh_auto_install: $(PYTHON3:%=install-python%)
-# dh_auto_install
+override_dh_install:
+ dh_install -Xbitmask/core -Xbitmask/cli
+ rm -rf src/leap.bitmask.egg-info
+ mv src/leap.bitmask.egg-info.orig src/leap.bitmask.egg-info
# build and install sphinx docs
#
@@ -68,9 +69,12 @@ override_dh_auto_clean:
rm -rf .tox
rm -rf bin
rm -rf build
+ rm -rf dist
rm -rf lib/
rm -rf docs/_build
rm -rf *.egg-info
+ rm -rf .eggs/
rm -f docs/man/bitmask.1
rm -f docs/man/bitmask-root.1
rm -rf docs/covhtml
+ rm -rf docker
diff --git a/debian/source/include-binaries b/debian/source/include-binaries
deleted file mode 100644
index 9868b8e2..00000000
--- a/debian/source/include-binaries
+++ /dev/null
@@ -1 +0,0 @@
-dist/leap_client-0.1dev-py2.7.egg