summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 9733f76d..2e4af44b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,10 @@ PYTHON2=$(shell pyversions -vr)
%:
dh $@ --with python2,sphinxdoc --buildsystem=python_distutils
+override_dh_prep:
+ rst2man docs/man/leap-client.1.rst docs/man/leap-client.1
+ dh_prep
+
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# run tests!
@@ -25,12 +29,6 @@ test-python%:
override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
endif
-override_dh_preps:
- # XXX trying to generate the manpage from rst,
- # but not the right override... :(
- rst2html docs/man/leap-client.1.rst docs/man/leap-client.1
- dh_preps
-
#dh_auto_build should be enough to build the python2 version
build-python%: