summaryrefslogtreecommitdiff
path: root/README.txt
diff options
context:
space:
mode:
Diffstat (limited to 'README.txt')
-rw-r--r--README.txt81
1 files changed, 71 insertions, 10 deletions
diff --git a/README.txt b/README.txt
index 14ac253f..a7c03f80 100644
--- a/README.txt
+++ b/README.txt
@@ -1,22 +1,79 @@
========================================
= LEAP =
-= The Internet Encryption Toolkit =
+= The LEAP Encryption Access Project =
+= your internet encryption toolkit =
========================================
+Installation
+=============
+
+Dependencies
+--------------
+
+* python <= 2.7
+* python setuptools
+* qt4 libraries
+* python-qt4
+* python-nose, python-mock, python-coverage (if you want to run tests)
+
+If you are on a debian-based system, you can run:
+
+apt-get install python-qt4 python-qt4-doc pyqt4-dev-tools python-setuptools python-nose
+
Install
-=======
+---------------
+
+If not using virtualenv:
+sudo python setup.py install
+
+If using virtualenv:
python setup.py install
+
+Running the App
+-----------------
+
+You need to set up a provider in your eip.cfg file:
+
+cd ~/.config/leap
+vim eip.cfg
+
+[provider]
+remote_ip = XXX.XXX.XXX.XXX
+
+and then run:
+
+leap --debug
+
+(or python app.py --debug if you run it from the src/leap folder).
+
+Development
+==============
+
Running tests
-=============
-nosetests -v
+-------------
+
+./run_tests.sh
+
+force no virtualenv and create coverage reports:
+./run_tests.sh -N -c
+
+if you want to run specific tests, pass the (sub)module to nose:
-Deps
-====
-apt-get install python-qt4 python-qt4-doc pyqt4-dev-tools
+nosetests leap.util
+
+or
+
+nosetests leap.util.test_leap_argparse
+
+
+Test-deps
+---------
+
+have a look at setup/test-requires
Hack
-====
+--------------
(recommended)
virtualenv . # ensure your .gitignore knows about it
@@ -25,10 +82,14 @@ bin/activate
# you should probably simlink sip.so and PyQt4 to your system-wide
# install, there are some issues with it.
-python setup.py develop # ... TBD: finish develop howto.
+python setup.py develop
+
+# ... TBD: finish develop howto.
+# ... and explain how is python setup develop useful.
Compiling resource/ui files
-===========================
+-----------------------------
+
You should refresh resource/ui files every time you
change an image or a resource/ui (.ui / .qc). From
the root folder: