summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 59343dfc..39157a5a 100644
--- a/Makefile
+++ b/Makefile
@@ -45,8 +45,10 @@ $(COMPILED_DIR)/%_rc.py : $(RESOURCE_DIR)/%.qrc
$(PYRCC) $< -o $@
deb:
- @git tag -a debian/$(DEBVER) -m "..."
- @debuild -us -uc -i.git
+ #XXX finish this!
+ #should tag upstream/VERSION in upstream branch...
+ #@git tag -a upstream/$(DEBVER) -m "..."
+ @git-buildpackage --git-ignore-new --git-builder="debuild -us -uc -i'.*|bin|share|lib|local|include|\.git'" --git-upstream-branch=upstream --git-upstream-tree=branch --git-debian-branch=debian
clean :
$(RM) $(COMPILED_UI) $(COMPILED_RESOURCES) $(COMPILED_UI:.py=.pyc) $(COMPILED_RESOURCES:.py=.pyc)