summaryrefslogtreecommitdiff
path: root/src/leap/gui/firstrun/providersetup.py
diff options
context:
space:
mode:
authorkali <kali@leap.se>2012-11-08 08:37:24 +0900
committerkali <kali@leap.se>2012-11-08 08:37:24 +0900
commitb84007d8fec8c949ba4ac1d26695c710a210d797 (patch)
treee9552e9925c103618e2ae6a9161105ab9e1317bd /src/leap/gui/firstrun/providersetup.py
parent8a70d249df9782a370c00a37de9a7d3af568c0f5 (diff)
more careful error catching during registration.
added a twisted server that fakes some of the provider interaction.
Diffstat (limited to 'src/leap/gui/firstrun/providersetup.py')
-rw-r--r--src/leap/gui/firstrun/providersetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/leap/gui/firstrun/providersetup.py b/src/leap/gui/firstrun/providersetup.py
index c039dfc5..2609629a 100644
--- a/src/leap/gui/firstrun/providersetup.py
+++ b/src/leap/gui/firstrun/providersetup.py
@@ -100,7 +100,8 @@ class ProviderSetupValidationPage(ValidationPage):
if self.errors:
print 'going back with errors'
wizard.set_validation_error(
- 'signup', 'that name is taken')
+ 'providerselection',
+ 'error on provider setup')
self.go_back()
else:
print 'going next'