summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2013-11-05 11:41:27 -0200
committerKali Kaneko <kali@leap.se>2013-11-05 11:41:27 -0200
commit603385e3f539e382077e8681cdd2477a7e0733ea (patch)
tree1d6d8f3e6e18d6d0d0fb3f629ab131f2dd366980 /setup.py
parenta6d8eb70ed15ab339d695eacd3cae58a2e561ba8 (diff)
parent23e9034664edf6b2a01a677c4fa4e6efd880e364 (diff)
Merge tag '0.3.6' into debian
Tag leap.bitmask version 0.3.6
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 2 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 67258ba1..87a55900 100755
--- a/setup.py
+++ b/setup.py
@@ -216,25 +216,8 @@ setup(
cmdclass=cmdclass,
description=("The Internet Encryption Toolkit: "
"Encrypted Internet Proxy and Encrypted Mail."),
- # XXX unify the long_description on a file of its own, so we
- # can reuse it easily.
- long_description=(
- "Bitmask is the multiplatform desktop client for the LEAP Platform."
- "\n"
- "The LEAP Encryption Access Project develops "
- "a multi-year plan to secure everyday communication.\n "
- "The Encrypted Internet Proxy (EIP) provides circumvention, location "
- "anonymization, and traffic encryption in a hassle-free, "
- "automatically self-configuring fashion.\n"
- "Encrypted Mail offers automatic encryption and decryption for "
- "both outgoing and incoming email, adding public key cryptography "
- "to your mail without you ever having to worry about key distribution "
- "or signature verification. \n"
- "The Encrypted Mail services will run local SMTP and IMAP proxies "
- "that, once you configure the mail client of your choice, will "
- "automatically encrypt and decrypt your email using GPG encryption "
- "under the hood."
- ),
+ long_description=open('README.rst').read() + '\n\n\n' +
+ open('CHANGELOG.rst').read(),
classifiers=trove_classifiers,
install_requires=parsed_reqs,
test_suite='nose.collector',