diff options
author | kali <kali@leap.se> | 2012-09-06 06:14:07 +0900 |
---|---|---|
committer | kali <kali@leap.se> | 2012-09-06 06:14:07 +0900 |
commit | 0932d79369fe381c20f4b8f0260a1cd850d979a7 (patch) | |
tree | 5fc8f531f54d0f4fe83a2298827e74a03bc296f6 /setup.py | |
parent | bb5d092b6f57321a12f0d7575e221b0cc68f063d (diff) | |
parent | 212f9588e458d5c864134caa8dafbef164631671 (diff) |
Merge branch 'feature/fix-setup-deps' into develop
Closes #405
Several fixes on setup.py:
It now reads requirements from pkg/requirements.pip
Version is extracted from git describe.
Added trove_classifiers metadata.
Added bootstrap for setuptools.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 83 |
1 files changed, 42 insertions, 41 deletions
@@ -6,56 +6,57 @@ import sys try: from setuptools import setup, find_packages except ImportError: - #FIXME old? - #use distribute_setup instead?? - #http://packages.python.org/distribute/setuptools.html#using-setuptools-without-bundling-it - import ez_setup - #XXX move ez_setup somewhere else? - ez_setup.use_setuptools() + from pkg import distribute_setup + distribute_setup.use_setuptools() from setuptools import setup, find_packages import os -# get version from somewhere else -version = '0.1' +from pkg import utils +from pkg import version setup_root = os.path.dirname(__file__) sys.path.insert(0, os.path.join(setup_root, "src")) +trove_classifiers = [ + "Development Status :: 3 - Alpha", + "Environment :: X11 Applications :: Qt", + "Intended Audience :: End Users/Desktop", + ("License :: OSI Approved :: GNU General " + "Public License v3 or later (GPLv3+)"), + "Operating System :: OS Independent", + "Programming Language :: Python", + "Programming Language :: Python :: 2.6", + "Programming Language :: Python :: 2.7", + "Topic :: Communications", + "Topic :: Security", + "Topic :: System :: Networking", + "Topic :: Utilities" +] + setup( name='leap-client', package_dir={"": "src"}, - version=version, + version=version.get_git_version(), description="the internet encryption toolkit", - long_description="""\ -""", - classifiers=[], # Get strings from - # http://pypi.python.org/pypi?%3Aaction=list_classifiers - - # XXX FIXME DEPS - # deps: pyqt - - # build_deps: pyqt-utils - # XXX fixme move resource reloading - # to this setup script. - - # XXX should implement a parse_requirements - # and get them from the pip reqs. workaround needed - # for argparse and <=2.6 - install_requires=[ - # -*- Extra requirements: -*- - "configuration", - "requests", - ], + long_description=( + "Desktop Client for the LEAP Platform." + "\n" + "LEAP (LEAP Encryption Access Project) develops " + "a multi-year plan to secure everyday communication, breaking down" + "into discrete services, to be rolled out one at a time.\n" + "The client for the current phase gives support to the EIP Service." + "EIP (the Encrypted Internet Proxy) provides circumvention, location " + "anonymization, and traffic " + "encryption in a hassle-free, automatically self-configuring fashion, " + "and has an enhanced level of security." + ), + classifiers=trove_classifiers, + install_requires=utils.parse_requirements(), test_suite='nose.collector', - - # XXX change to parse_test_requirements and - # get them from pip reqs. - test_requires=[ - "nose", - "mock"], - - keywords='leap, client, qt, encryption', - author='leap project', + test_requires=utils.parse_requirements( + reqfiles=['pkg/test-requirements.pip']), + keywords='leap, client, qt, encryption, proxy', + author='The LEAP project', author_email='info@leap.se', url='http://leap.se', license='GPL', @@ -65,15 +66,15 @@ setup( include_package_data=True, zip_safe=False, - # XXX platform switch + # add platform switch data_files=[ ("share/man/man1", ["docs/leap.1"]), ("share/polkit-1/actions", - ["setup/linux/polkit/net.openvpn.gui.leap.policy"]) + ["pkg/linux/polkit/net.openvpn.gui.leap.policy"]) ], platforms="all", - scripts=["setup/scripts/leap"], + scripts=["pkg/scripts/leap"], entry_points=""" # -*- Entry points: -*- """, |