diff options
author | Kali Kaneko <kali@leap.se> | 2015-08-12 12:19:00 -0400 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2015-08-12 12:19:00 -0400 |
commit | 4f0f6ec24e0e6e1d27509130c0aae3b818f19195 (patch) | |
tree | f93f2b0929c02cb5cd14195582a5d30ea58f2db8 /setup.py | |
parent | bb808bb42046eb71411b2a4528e1820801428a7a (diff) |
[bug] freeze also bitmask module version in sumo tarball
if __version__ is not properly assigned, provider tests were breaking
when parsing BITMASK_VERSION (which is None, where a string is
expected).
- Resolves: #7322
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -322,8 +322,13 @@ class cmd_sdist(versioneer_sdist): src_path) all_module_files = list_recursively(src_path) self.filelist.extend(all_module_files) + module_ver = vdict[module] freeze_pkg_ver( - src_path + "/_version.py", vdict[module], "sumo") + src_path + "/_version.py", + module_ver, "%s-sumo" % module_ver) + freeze_pkg_ver( + "src/leap/bitmask/_version.py", + VERSION, "%s-sumo" % VERSION) # In addition, we want the tarball/zipfile to have -SUMO in the # name, and the unpacked directory to have -SUMO too. The easiest |