diff options
author | Kali Kaneko <kali@leap.se> | 2013-09-04 18:15:31 +0200 |
---|---|---|
committer | Kali Kaneko <kali@leap.se> | 2013-09-04 18:15:31 +0200 |
commit | 9e47e7695e25802f7f0e33deacb940ce72720486 (patch) | |
tree | 92c6ef700a98fca6af34f56d1561bfeb3ec76826 /setup.py | |
parent | f688bae3beb8b011c643e2d17c62618cfdc89f6c (diff) | |
parent | 845d70c8efb70478cb19fcc88e0c7958ee75370c (diff) |
Merge remote-tracking branch 'ivan-github/bug/3675_qfiledialog-and-qtreactor-freezes' into develop
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 23 |
1 files changed, 23 insertions, 0 deletions
@@ -1,10 +1,33 @@ #!/usr/bin/env python # -*- coding: utf-8 -*- +# setup.py +# Copyright (C) 2013 LEAP +# +# This program is free software: you can redistribute it and/or modify +# it under the terms of the GNU General Public License as published by +# the Free Software Foundation, either version 3 of the License, or +# (at your option) any later version. +# +# This program is distributed in the hope that it will be useful, +# but WITHOUT ANY WARRANTY; without even the implied warranty of +# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the +# GNU General Public License for more details. +# +# You should have received a copy of the GNU General Public License +# along with this program. If not, see <http://www.gnu.org/licenses/>. +""" +Setup file for bitmask. +""" from __future__ import print_function import sys +if not sys.version_info[0] == 2: + print("[ERROR] Sorry, Python 3 is not supported (yet). " + "Try running with python2: python2 setup.py ...") + exit() + try: from setuptools import setup, find_packages except ImportError: |