summaryrefslogtreecommitdiff
path: root/pkg
diff options
context:
space:
mode:
authorKali Kaneko <kali@leap.se>2016-04-25 22:13:19 -0400
committerKali Kaneko <kali@leap.se>2016-04-26 21:33:34 -0400
commit3b3731d873664db00c02603363f61d34c41a3990 (patch)
tree13293a9aee4253f8e4bcad5c37f97230b8f200eb /pkg
parent005f3f5e5157bddf792f46a983bfadd0d4398a89 (diff)
embed pixelated
Diffstat (limited to 'pkg')
-rw-r--r--pkg/pyinst/bitmask.spec.orig38
-rw-r--r--pkg/pyinst/pyinst-build.mk3
2 files changed, 2 insertions, 39 deletions
diff --git a/pkg/pyinst/bitmask.spec.orig b/pkg/pyinst/bitmask.spec.orig
deleted file mode 100644
index 617104b9..00000000
--- a/pkg/pyinst/bitmask.spec.orig
+++ /dev/null
@@ -1,38 +0,0 @@
-# -*- mode: python -*-
-
-block_cipher = None
-
-
-a = Analysis([os.path.join('bitmask.py')],
- hiddenimports=[
- 'zope.interface', 'zope.proxy',
- 'PySide.QtCore', 'PySide.QtGui'],
- hookspath=None,
- runtime_hooks=None,
- excludes=None,
- cipher=block_cipher)
-pyz = PYZ(a.pure,
- cipher=block_cipher)
-exe = EXE(pyz,
- a.scripts,
- exclude_binaries=True,
- name='bitmask',
- debug=False,
- strip=False,
- upx=True,
- console=False )
-coll = COLLECT(exe,
- a.binaries,
- a.zipfiles,
- a.datas,
- strip=False,
- upx=True,
- name='bitmask')
-if sys.platform.startswith("darwin"):
- app = BUNDLE(coll,
- name=os.path.join(
- 'dist', 'Bitmask.app'),
- appname='Bitmask',
- version='0.9.0rc2',
- icon='pkg/osx/bitmask.icns',
- bundle_identifier='bitmask-0.9.0rc2')
diff --git a/pkg/pyinst/pyinst-build.mk b/pkg/pyinst/pyinst-build.mk
index 92a1cbb3..3c514a02 100644
--- a/pkg/pyinst/pyinst-build.mk
+++ b/pkg/pyinst/pyinst-build.mk
@@ -22,7 +22,8 @@ reset-ver:
pyinst-hacks-linux:
# XXX this should be taken care of by pyinstaller data collector
- cp $(VIRTUAL_ENV)/lib/python2.7/site-packages/leap/common/cacert.pem $(DIST)
+ #cp $(VIRTUAL_ENV)/lib/python2.7/site-packages/leap/common/cacert.pem $(DIST)
+ cp ../leap_common/src/leap/common/cacert.pem $(DIST)
mkdir -p $(DIST)pysqlcipher
mkdir -p $(DIST)pixelated
mkdir -p $(DIST)twisted/web