summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorantialias <antialias@leap.se>2012-08-14 13:41:01 -0700
committerantialias <antialias@leap.se>2012-08-14 13:41:01 -0700
commitbc44a763808241ec4e732e7b3bbd819490c88cbb (patch)
treea55f7c670dbd051981ce65c37da5320a5e980990 /debian/rules
parente1103904fbdd9b54b53075956c279271c17e9a8f (diff)
parentb0ef9f98d8384cb68e59fac91142e5ac9f2ab47c (diff)
Merge branch 'develop' of ssh://leap.se:4422/leap-client into refactor
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules59
1 files changed, 0 insertions, 59 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index ec47a76b..00000000
--- a/debian/rules
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-#
-#
-
-# needed???
-# DEB_PYTHON_SYSTEM=pysupport
-
-# Uncomment this to turn on verbose mode.
-#DH_VERBOSE=1
-
-PYTHON2=$(shell pyversions -vr)
-
-%:
- dh $@ --with python2
- #,sphinxdoc
-
-ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
-
-# run tests!
-#
-test-python%:
- python$* setup.py test -vv
-
-override_dh_auto_test: $(PYTHON2:%=test-python%) $(PYTHON3:%=test-python%)
-endif
-
-#dh_auto_build should be enough to build the python2 version
-
-#build-python%:
-# python$* setup.py build
-
-#override_dh_auto_build: $(PYTHON3:%=build-python%)
-# dh_auto_build
-
-#install-python%:
-# python$* setup.py install --root=$(CURDIR)/debian/tmp --install-layout=deb
-
-#override_dh_auto_install: $(PYTHON3:%=install-python%)
-# dh_auto_install
-
-override_dh_installchangelogs:
- dh_installchangelogs -k CHANGES.txt
-
-# build and install sphinx docs
-#
-#override_dh_installdocs:
-# python setup.py build_sphinx
-# dh_installdocs build/sphinx/html
-
-override_dh_auto_clean:
- dh_auto_clean
- rm -rf build
- rm -rf *.egg-info